summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-07-03 20:57:17 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-07-03 20:57:27 +0100
commit43fbec44acb0b56b2443f99e0994d5636c98d916 (patch)
tree3a37449b57da044b9f435ae3f80f6686e2aaf40c /dev-lang
parentmedia-plugins/vdr-xineliboutput: set vdr project as maintainer (diff)
downloadgentoo-43fbec44acb0b56b2443f99e0994d5636c98d916.tar.gz
gentoo-43fbec44acb0b56b2443f99e0994d5636c98d916.tar.bz2
gentoo-43fbec44acb0b56b2443f99e0994d5636c98d916.zip
dev-lang/ghc: add a ncurses:5/5 binary dependency, bug #561276
Reported-by: Erich Seifert Bug: https://bugs.gentoo.org/561276 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ghc-7.10.3.ebuild21
-rw-r--r--dev-lang/ghc/ghc-7.8.4.ebuild21
-rw-r--r--dev-lang/ghc/ghc-8.0.2.ebuild12
3 files changed, 20 insertions, 34 deletions
diff --git a/dev-lang/ghc/ghc-7.10.3.ebuild b/dev-lang/ghc/ghc-7.10.3.ebuild
index 9945f4816692..fb6bc873376f 100644
--- a/dev-lang/ghc/ghc-7.10.3.ebuild
+++ b/dev-lang/ghc/ghc-7.10.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -83,27 +83,20 @@ RDEPEND="
sys-libs/ncurses:=[unicode]
!ghcmakebinary? ( virtual/libffi:= )
"
-# gentoo binaries are built against ncurses-5
-RDEPEND+="
- binary? (
- || (
- sys-libs/ncurses:0/5
- sys-libs/ncurses:5/5
- )
- )
+
+PREBUILT_BINARY_DEPENDS="
+ !prefix? ( elibc_glibc? ( >=sys-libs/glibc-2.17 ) )
+ sys-libs/ncurses:5/5
"
-# force dependency on >=gmp-5, even if >=gmp-4.1 would be enough. this is due to
-# that we want the binaries to use the latest versioun available, and not to be
-# built against gmp-4
+RDEPEND+="binary? ( ${PREBUILT_BINARY_DEPENDS} )"
-# similar for glibc. we have bootstrapped binaries against glibc-2.17
DEPEND="${RDEPEND}
doc? ( app-text/docbook-xml-dtd:4.2
app-text/docbook-xml-dtd:4.5
app-text/docbook-xsl-stylesheets
>=dev-libs/libxslt-1.1.2 )
- !ghcbootstrap? ( !prefix? ( elibc_glibc? ( >=sys-libs/glibc-2.17 ) ) )"
+ !ghcbootstrap? ( ${PREBUILT_BINARY_DEPENDS} )"
PDEPEND="!ghcbootstrap? ( =app-admin/haskell-updater-1.2* )"
diff --git a/dev-lang/ghc/ghc-7.8.4.ebuild b/dev-lang/ghc/ghc-7.8.4.ebuild
index 00c4b0e0dfa4..659446b80e5e 100644
--- a/dev-lang/ghc/ghc-7.8.4.ebuild
+++ b/dev-lang/ghc/ghc-7.8.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -76,28 +76,21 @@ RDEPEND="
sys-libs/ncurses:=[unicode]
!ghcmakebinary? ( virtual/libffi:= )
"
-# gentoo binaries are built against ncurses-5
-RDEPEND+="
- binary? (
- || (
- sys-libs/ncurses:0/5
- sys-libs/ncurses:5/5
- )
- )
+
+PREBUILT_BINARY_DEPENDS="
+ !prefix? ( elibc_glibc? ( >=sys-libs/glibc-2.17 ) )
+ sys-libs/ncurses:5/5
"
-# force dependency on >=gmp-5, even if >=gmp-4.1 would be enough. this is due to
-# that we want the binaries to use the latest versioun available, and not to be
-# built against gmp-4
+RDEPEND+="binary? ( ${PREBUILT_BINARY_DEPENDS} )"
-# similar for glibc. we have bootstrapped binaries against glibc-2.17
DEPEND="${RDEPEND}
ghcbootstrap? (
doc? ( app-text/docbook-xml-dtd:4.2
app-text/docbook-xml-dtd:4.5
app-text/docbook-xsl-stylesheets
>=dev-libs/libxslt-1.1.2 ) )
- !ghcbootstrap? ( !prefix? ( elibc_glibc? ( >=sys-libs/glibc-2.17 ) ) )"
+ !ghcbootstrap? ( ${PREBUILT_BINARY_DEPENDS} )"
PDEPEND="!ghcbootstrap? ( =app-admin/haskell-updater-1.2* )"
diff --git a/dev-lang/ghc/ghc-8.0.2.ebuild b/dev-lang/ghc/ghc-8.0.2.ebuild
index 35b9ae7f93a4..61c62ccf6fae 100644
--- a/dev-lang/ghc/ghc-8.0.2.ebuild
+++ b/dev-lang/ghc/ghc-8.0.2.ebuild
@@ -81,20 +81,20 @@ RDEPEND="
sys-libs/ncurses:=[unicode]
!ghcmakebinary? ( virtual/libffi:= )
"
-# gentoo binaries are built against ncurses-6
-RDEPEND+="
- binary? (
- sys-libs/ncurses:0/6
- )
+
+PREBUILT_BINARY_DEPENDS="
+ sys-libs/ncurses:0/6
"
+RDEPEND+="binary? ( ${PREBUILT_BINARY_DEPENDS} )"
+
DEPEND="${RDEPEND}
doc? ( app-text/docbook-xml-dtd:4.2
app-text/docbook-xml-dtd:4.5
app-text/docbook-xsl-stylesheets
dev-python/sphinx
>=dev-libs/libxslt-1.1.2 )
-"
+ !ghcbootstrap? ( ${PREBUILT_BINARY_DEPENDS} )"
PDEPEND="!ghcbootstrap? ( =app-admin/haskell-updater-1.2* )"