summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-02 08:11:25 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-02 08:13:44 +0100
commit5bdbf7c9a0550be4eb7b0d4752327d290d0376c0 (patch)
treeda79470877b79b302d917dab99daf10e40c2f369 /dev-lang
parentdev-lang/icon: Stabilize 9.5.22e hppa, #940088 (diff)
downloadgentoo-5bdbf7c9a0550be4eb7b0d4752327d290d0376c0.tar.gz
gentoo-5bdbf7c9a0550be4eb7b0d4752327d290d0376c0.tar.bz2
gentoo-5bdbf7c9a0550be4eb7b0d4752327d290d0376c0.zip
dev-lang/ispc: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ispc/Manifest2
-rw-r--r--dev-lang/ispc/ispc-1.25.0.ebuild95
-rw-r--r--dev-lang/ispc/ispc-1.25.1.ebuild95
3 files changed, 0 insertions, 192 deletions
diff --git a/dev-lang/ispc/Manifest b/dev-lang/ispc/Manifest
index 3d54d3ad6d7a..f66835fed224 100644
--- a/dev-lang/ispc/Manifest
+++ b/dev-lang/ispc/Manifest
@@ -1,4 +1,2 @@
DIST ispc-1.24.0.gh.tar.gz 19674211 BLAKE2B 246a079f03fa17f1ab4d80c55b992e92f44d5395e3f1feadee90c773771496ead4de0671b3869c70d5a93038d7c0ccaf9ed3ad5b5e40eb156d605a73150b15d9 SHA512 ad9feab1b5986471a52c775c1220ae46904ae952b33a14299f525eb03e004c6e1395dd171ddedee833892d57ad195ffddb234b26a2df42138fb1b2364b62803e
-DIST ispc-1.25.0.gh.tar.gz 19805576 BLAKE2B 02daf70f7a7a0bbaf35799620f3475da117b42f2fb09ec2799c47617108b55e68cd241321d14bbbbf8968d48de38e98bd44565f967dfa97b7a66c87c32acedfb SHA512 0d5c23ce1e57f38a7563b1d2c4813cbb5aa082f19257d3831f8cef8f6bb51d0c8b9ecce142497c13015b64731c98afb0b13ebc80663c83ded9b005e1e1608fd5
-DIST ispc-1.25.1.gh.tar.gz 19804554 BLAKE2B 2f6fda1a3209307809780118ce917ec418f674ce2bc4d283af94166153de7a9627a833f7d4e9c0f3506f8ca3e54dae38fe0481d6eaf9e7fefd1cbaaa824c453c SHA512 467148ac7b5bcdc17cb580430e9a3c669f63b239802bc19e1e2d7dcb6762eeacfdc944f51cad6277ec52f5858e11d8f2a1d3e0b961eeb97a9081e6e2efd9e9b6
DIST ispc-1.25.2.gh.tar.gz 19805407 BLAKE2B d4722725778f06a963a9bbc2fa691707e51b907fcc6cabac5987a7dcd65cc6855f27d4bd2559f6e79185067de7211ec9da48635c29d146c6525963db2f0fa11a SHA512 29c0adb0d28be280ef6223253f34eaeae6530d4ab63f67c94791837144eb20a2d596b0bd450188841b86f277d9f7d68a96b3c1e9e25297590e496d7f04ad55c3
diff --git a/dev-lang/ispc/ispc-1.25.0.ebuild b/dev-lang/ispc/ispc-1.25.0.ebuild
deleted file mode 100644
index d6b6ef1352c9..000000000000
--- a/dev-lang/ispc/ispc-1.25.0.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LLVM_COMPAT=( {17..19} )
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit cmake llvm-r1 multiprocessing python-any-r1 toolchain-funcs
-
-DESCRIPTION="Intel SPMD Program Compiler"
-HOMEPAGE="
- https://ispc.github.io/
- https://github.com/ispc/ispc/
-"
-SRC_URI="
- https://github.com/ispc/ispc/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD BSD-2 UoI-NCSA"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="examples gpu openmp test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- $(llvm_gen_dep '
- sys-devel/clang:${LLVM_SLOT}
- ')
- sys-libs/ncurses:=
- gpu? ( dev-libs/level-zero:= )
- !openmp? ( dev-cpp/tbb:= )
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- app-alternatives/yacc
- app-alternatives/lex
- ${PYTHON_DEPS}
-"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
- llvm-r1_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- # do not require bundled gtest
- mkdir -p ispcrt/tests/vendor/google/googletest || die
- cat > ispcrt/tests/vendor/google/googletest/CMakeLists.txt <<-EOF || die
- find_package(GTest)
- EOF
- # remove hacks that break unbundling
- sed -i -e '/gmock/d' -e '/install/,$d' ispcrt/tests/CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DARM_ENABLED=$(usex arm)
- -DCMAKE_SKIP_RPATH=ON
- -DISPC_INCLUDE_EXAMPLES=OFF
- -DISPC_INCLUDE_TESTS=$(usex test)
- -DISPC_INCLUDE_UTILS=OFF
- -DISPCRT_BUILD_GPU=$(usex gpu)
- -DISPCRT_BUILD_TASK_MODEL=$(usex openmp OpenMP TBB)
- # prevent it from trying to find the git repo
- -DGIT_BINARY=GIT_BINARY-NOTFOUND
- )
- cmake_src_configure
-}
-
-src_test() {
- # Inject path to prevent using system ispc
- local -x PATH="${BUILD_DIR}/bin:${PATH}"
- "${EPYTHON}" ./scripts/run_tests.py "-j$(makeopts_jobs)" -v ||
- die "Testing failed under ${EPYTHON}"
-}
-
-src_install() {
- cmake_src_install
-
- if use examples; then
- docompress -x /usr/share/doc/${PF}/examples
- dodoc -r examples
- fi
-}
diff --git a/dev-lang/ispc/ispc-1.25.1.ebuild b/dev-lang/ispc/ispc-1.25.1.ebuild
deleted file mode 100644
index d6b6ef1352c9..000000000000
--- a/dev-lang/ispc/ispc-1.25.1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LLVM_COMPAT=( {17..19} )
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit cmake llvm-r1 multiprocessing python-any-r1 toolchain-funcs
-
-DESCRIPTION="Intel SPMD Program Compiler"
-HOMEPAGE="
- https://ispc.github.io/
- https://github.com/ispc/ispc/
-"
-SRC_URI="
- https://github.com/ispc/ispc/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD BSD-2 UoI-NCSA"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="examples gpu openmp test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- $(llvm_gen_dep '
- sys-devel/clang:${LLVM_SLOT}
- ')
- sys-libs/ncurses:=
- gpu? ( dev-libs/level-zero:= )
- !openmp? ( dev-cpp/tbb:= )
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- app-alternatives/yacc
- app-alternatives/lex
- ${PYTHON_DEPS}
-"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
- llvm-r1_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- # do not require bundled gtest
- mkdir -p ispcrt/tests/vendor/google/googletest || die
- cat > ispcrt/tests/vendor/google/googletest/CMakeLists.txt <<-EOF || die
- find_package(GTest)
- EOF
- # remove hacks that break unbundling
- sed -i -e '/gmock/d' -e '/install/,$d' ispcrt/tests/CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DARM_ENABLED=$(usex arm)
- -DCMAKE_SKIP_RPATH=ON
- -DISPC_INCLUDE_EXAMPLES=OFF
- -DISPC_INCLUDE_TESTS=$(usex test)
- -DISPC_INCLUDE_UTILS=OFF
- -DISPCRT_BUILD_GPU=$(usex gpu)
- -DISPCRT_BUILD_TASK_MODEL=$(usex openmp OpenMP TBB)
- # prevent it from trying to find the git repo
- -DGIT_BINARY=GIT_BINARY-NOTFOUND
- )
- cmake_src_configure
-}
-
-src_test() {
- # Inject path to prevent using system ispc
- local -x PATH="${BUILD_DIR}/bin:${PATH}"
- "${EPYTHON}" ./scripts/run_tests.py "-j$(makeopts_jobs)" -v ||
- die "Testing failed under ${EPYTHON}"
-}
-
-src_install() {
- cmake_src_install
-
- if use examples; then
- docompress -x /usr/share/doc/${PF}/examples
- dodoc -r examples
- fi
-}