summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-12 00:20:58 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-12 01:30:54 +0200
commitc02fb81d066dfa243e99e7e1ce86be330c666efa (patch)
treefc32e47344414ddca82c6b2db5772f2b603f67ba /dev-lang
parentdev-lang/typescript: drop old 5.5.3 (diff)
downloadgentoo-c02fb81d066dfa243e99e7e1ce86be330c666efa.tar.gz
gentoo-c02fb81d066dfa243e99e7e1ce86be330c666efa.tar.bz2
gentoo-c02fb81d066dfa243e99e7e1ce86be330c666efa.zip
dev-lang/typescript: bump to 5.6.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/typescript/Manifest1
-rw-r--r--dev-lang/typescript/typescript-5.6.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-lang/typescript/Manifest b/dev-lang/typescript/Manifest
index bd19e849f399..b96aae2347cf 100644
--- a/dev-lang/typescript/Manifest
+++ b/dev-lang/typescript/Manifest
@@ -1 +1,2 @@
DIST typescript-5.5.4.tgz 4043150 BLAKE2B 6171a4bafcb7d9dff4cd603846980bcfa599c4ee13d585760af572dc410a584f729485bc2aaf5cb5e3721d37b7cf8d4f54eaf9abda86eba04bf54b50ac80db9c SHA512 32dab6f6c28300460feda963460b4f3a94ef39f6f0456952e9d3d1cf08dd13e0b44786eb5ff194ca11d279c6c73052cd04b70920fb7d9e5f721b94d9d70787f9
+DIST typescript-5.6.2.tgz 4174769 BLAKE2B dad7a57b0caf704e8723021b83c53b392d945b0ac529a1be568297875eceecedbd84f5d1bb967313284d8ce8195b6f2b61c19ca0da79f22a27846cf944057f83 SHA512 356f01ca874248d0b065e8218cdde8f895f93851f43a383ab1a76310a63886e679d93a9b2532670e8e7e4f0f7c952cbadcd66f8b89fe7b3e66daee5de0f919cb
diff --git a/dev-lang/typescript/typescript-5.6.2.ebuild b/dev-lang/typescript/typescript-5.6.2.ebuild
new file mode 100644
index 000000000000..242c85963aec
--- /dev/null
+++ b/dev-lang/typescript/typescript-5.6.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org/
+ https://github.com/microsoft/TypeScript/"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a myopts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${myopts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ dodoc *.md *.txt
+}