summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2023-01-13 17:57:44 +0600
committerSam James <sam@gentoo.org>2023-01-14 19:14:52 +0000
commite27d250289fea5fed738efbc2f64b5e6e5a86386 (patch)
treeaa09d09f52ac2285b9f8511853d8aed8c873bdd9 /dev-lang
parentdev-lang/zig: fix patch from previous commit (diff)
downloadgentoo-e27d250289fea5fed738efbc2f64b5e6e5a86386.tar.gz
gentoo-e27d250289fea5fed738efbc2f64b5e6e5a86386.tar.bz2
gentoo-e27d250289fea5fed738efbc2f64b5e6e5a86386.zip
dev-lang/zig: use "edob" for testing 0.10.0
As suggested by Sam James. I'm not touching live version yet as PR is not merged yet and upstream plans to add some tests [that requires network access] for their newly-created package manager (literally today) and related stuff (TLS client/server etc.). I'll try to cooperate with them and add option that will skip these tests. Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Closes: https://github.com/gentoo/gentoo/pull/29090 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/zig/zig-0.10.0-r1.ebuild29
1 files changed, 12 insertions, 17 deletions
diff --git a/dev-lang/zig/zig-0.10.0-r1.ebuild b/dev-lang/zig/zig-0.10.0-r1.ebuild
index f47f22799167..4d9a45ee5fb0 100644
--- a/dev-lang/zig/zig-0.10.0-r1.ebuild
+++ b/dev-lang/zig/zig-0.10.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
LLVM_MAX_SLOT=15
-inherit cmake llvm check-reqs
+inherit edo cmake llvm check-reqs
DESCRIPTION="A robust, optimal, and maintainable programming language"
HOMEPAGE="https://ziglang.org/"
@@ -76,22 +76,17 @@ src_configure() {
src_test() {
cd "${BUILD_DIR}" || die
- local ZIG_TESTARGS=("-Dstatic-llvm=false -Denable-llvm=true -Dskip-non-native=true -Drelease -Dtarget=native")
- ./stage3/bin/zig build test-cases ${ZIG_TESTARGS[@]} || die
- ./stage3/bin/zig build test-fmt ${ZIG_TESTARGS[@]} || die
- ./stage3/bin/zig build test-behavior ${ZIG_TESTARGS[@]} || die
- ./stage3/bin/zig build test-compiler-rt ${ZIG_TESTARGS[@]} || die
- ./stage3/bin/zig build test-universal-libc ${ZIG_TESTARGS[@]} || die
- ./stage3/bin/zig build test-compare-output ${ZIG_TESTARGS[@]} || die
- ./stage3/bin/zig build test-standalone ${ZIG_TESTARGS[@]} || die
- ./stage3/bin/zig build test-c-abi ${ZIG_TESTARGS[@]} || die
- ./stage3/bin/zig build test-link ${ZIG_TESTARGS[@]} || die
- ./stage3/bin/zig build test-stack-traces ${ZIG_TESTARGS[@]} || die
- ./stage3/bin/zig build test-cli ${ZIG_TESTARGS[@]} || die
- ./stage3/bin/zig build test-asm-link ${ZIG_TESTARGS[@]} || die
- ./stage3/bin/zig build test-translate-c ${ZIG_TESTARGS[@]} || die
- ./stage3/bin/zig build test-run-translated-c ${ZIG_TESTARGS[@]} || die
- ./stage3/bin/zig build test-std ${ZIG_TESTARGS[@]} || die
+ local ZIG_TEST_ARGS="-Dstatic-llvm=false -Denable-llvm=true -Dskip-non-native=true -Drelease -Dtarget=native"
+ local ZIG_TEST_STEPS=(
+ test-cases test-fmt test-behavior test-compiler-rt test-universal-libc test-compare-output
+ test-standalone test-c-abi test-link test-stack-traces test-cli test-asm-link test-translate-c
+ test-run-translated-c test-std
+ )
+
+ local step
+ for step in "${ZIG_TEST_STEPS[@]}" ; do
+ edob ./stage3/bin/zig build ${step} ${ZIG_TEST_ARGS}
+ done
}
pkg_postinst() {