summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-09-07 10:53:22 -0400
committerMike Gilbert <floppym@gentoo.org>2018-09-07 13:18:44 -0400
commit3b520e5686ec099557f0ae8cd010616312045fb2 (patch)
treeef453c57e7f9253ab07500dedc39e54c5bbcd451 /dev-libs/atf/atf-0.21-r2.ebuild
parentwww-client/firefox: install language packs as XPI file (diff)
downloadgentoo-3b520e5686ec099557f0ae8cd010616312045fb2.tar.gz
gentoo-3b520e5686ec099557f0ae8cd010616312045fb2.tar.bz2
gentoo-3b520e5686ec099557f0ae8cd010616312045fb2.zip
dev-libs/atf: remove /usr/tests
Bug: https://bugs.gentoo.org/654496 Package-Manager: Portage-2.3.49_p2, Repoman-2.3.10_p48
Diffstat (limited to 'dev-libs/atf/atf-0.21-r2.ebuild')
-rw-r--r--dev-libs/atf/atf-0.21-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/atf/atf-0.21-r2.ebuild b/dev-libs/atf/atf-0.21-r2.ebuild
new file mode 100644
index 000000000000..81fad911bd9f
--- /dev/null
+++ b/dev-libs/atf/atf-0.21-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Libraries to write tests in C, C++ and shell"
+HOMEPAGE="https://github.com/jmmv/atf"
+SRC_URI="https://github.com/jmmv/atf/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-getopt-solaris.patch )
+
+src_install() {
+ default
+ rm -r "${ED%/}"/usr/tests || die
+ find "${ED}" -name '*.la' -delete || die
+}