summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-12 16:44:31 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-12 16:44:50 -0400
commitdb7625cc3c8155279a9cc2e2a7fcd0b77c4ca662 (patch)
treeb28e1f3f6fe255b0e88df3b8b3244c58630539af /dev-libs/check
parentdev-libs/check: remove three old versions. (diff)
downloadgentoo-db7625cc3c8155279a9cc2e2a7fcd0b77c4ca662.tar.gz
gentoo-db7625cc3c8155279a9cc2e2a7fcd0b77c4ca662.tar.bz2
gentoo-db7625cc3c8155279a9cc2e2a7fcd0b77c4ca662.zip
dev-libs/check: new revision with missing virtual/pkgconfig DEPEND.
Gentoo-Bug: 504658 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/check')
-rw-r--r--dev-libs/check/check-0.10.0-r1.ebuild (renamed from dev-libs/check/check-0.10.0.ebuild)22
1 files changed, 11 insertions, 11 deletions
diff --git a/dev-libs/check/check-0.10.0.ebuild b/dev-libs/check/check-0.10.0-r1.ebuild
index 2d86028f27b5..f0c21e31e6bc 100644
--- a/dev-libs/check/check-0.10.0.ebuild
+++ b/dev-libs/check/check-0.10.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -6,7 +6,7 @@ EAPI=5
AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
-inherit autotools autotools-multilib eutils
+inherit autotools autotools-multilib
DESCRIPTION="A unit test framework for C"
HOMEPAGE="https://sourceforge.net/projects/check/"
@@ -17,8 +17,9 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs subunit"
-DEPEND="subunit? ( >=dev-python/subunit-0.0.10-r1[${MULTILIB_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="subunit? ( >=dev-python/subunit-0.0.10-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
pkg_setup() {
# See multilib_src_test(), disable sleep()-based tests because they
@@ -27,14 +28,12 @@ pkg_setup() {
}
src_prepare() {
- sed -i -e '/^docdir =/d' {.,doc}/Makefile.am || die
+ sed -i -e '/^docdir =/d' {.,doc}/Makefile.am \
+ || die 'failed to unset docdir in Makefile.am'
# fix out-of-sourcedir build having inconsistent check.h files, for
# example breaks USE=subunit.
- rm src/check.h || die
-
- # Fix automake warnings being treated as errors, bug #420373
- sed -i -e s/-Werror// configure.ac || die
+ rm src/check.h || die 'failed to remove src/check.h'
eautoreconf
}
@@ -43,7 +42,7 @@ src_configure() {
local myeconfargs=(
--disable-dependency-tracking
$(use_enable subunit)
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
)
autotools-multilib_src_configure
}
@@ -59,5 +58,6 @@ src_install() {
autotools-multilib_src_install
dodoc AUTHORS *ChangeLog* NEWS README THANKS TODO
- rm -f "${ED}"/usr/share/doc/${PF}/COPYING* || die
+ rm -f "${ED}/usr/share/doc/${PF}"/COPYING* || \
+ die 'failed to remove COPYING files'
}