summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-08-24 17:53:51 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-08-24 17:56:28 +0100
commit67e8222782c481df97f2d1c5bc88d53113553efb (patch)
tree39747454289b3d879730bdb9008c7eea51061b4b /dev-libs/cyrus-sasl
parentx11-drivers/nvidia-drivers: drop 550.100, 555.58, 555.58.02, 560.31.02 (diff)
downloadgentoo-67e8222782c481df97f2d1c5bc88d53113553efb.tar.gz
gentoo-67e8222782c481df97f2d1c5bc88d53113553efb.tar.bz2
gentoo-67e8222782c481df97f2d1c5bc88d53113553efb.zip
dev-libs/cyrus-sasl: Fix empty sasldb2 generation when cross-compiling
This changes how the generation works as it now needs to be done in src_install while the native saslpasswd2 is still around, rather than in pkg_postinst. We cannot check EROOT during src_install, so we generate the empty file unconditionally. It is easiest to subsequently install this file unconditionally too but as sasldb2-empty. It is only copied to sasldb2 if that doesn't already exist. Keeping an empty file around is potentially useful anyway. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-libs/cyrus-sasl')
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.28-r5.ebuild246
1 files changed, 246 insertions, 0 deletions
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.28-r5.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.28-r5.ebuild
new file mode 100644
index 000000000000..358927ac57c3
--- /dev/null
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.28-r5.ebuild
@@ -0,0 +1,246 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools edos2unix flag-o-matic multilib multilib-minimal pam db-use systemd toolchain-funcs tmpfiles
+
+SASLAUTHD_CONF_VER="2.1.26"
+MY_PATCH_VER="${PN}-2.1.28-r4-patches"
+DESCRIPTION="The Cyrus SASL (Simple Authentication and Security Layer)"
+HOMEPAGE="https://www.cyrusimap.org/sasl/"
+#SRC_URI="ftp://ftp.cyrusimap.org/cyrus-sasl/${P}.tar.gz"
+SRC_URI="https://github.com/cyrusimap/${PN}/releases/download/${P}/${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~grobian/distfiles/${MY_PATCH_VER}.tar.xz"
+
+LICENSE="BSD-with-attribution"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="authdaemond berkdb gdbm kerberos ldapdb openldap mysql pam postgres sample selinux sqlite srp ssl static-libs urandom"
+REQUIRED_USE="ldapdb? ( openldap )"
+
+# See bug #855890 for sys-libs/db slot
+DEPEND="net-mail/mailbase
+ virtual/libcrypt:=
+ authdaemond? ( || ( net-mail/courier-imap mail-mta/courier ) )
+ berkdb? ( >=sys-libs/db-4.8.30-r1:4.8[${MULTILIB_USEDEP}] )
+ gdbm? ( >=sys-libs/gdbm-1.10-r1:=[${MULTILIB_USEDEP}] )
+ kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ openldap? ( >=net-nds/openldap-2.4.38-r1:=[${MULTILIB_USEDEP}] )
+ mysql? ( dev-db/mysql-connector-c:0=[${MULTILIB_USEDEP}] )
+ pam? ( >=sys-libs/pam-0-r1[${MULTILIB_USEDEP}] )
+ postgres? ( dev-db/postgresql:* )
+ sqlite? ( >=dev-db/sqlite-3.8.2:3[${MULTILIB_USEDEP}] )
+ ssl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-sasl )"
+BDEPEND="virtual/libcrypt
+ berkdb? ( >=sys-libs/db-4.8.30-r1:4.8 )
+ gdbm? ( >=sys-libs/gdbm-1.10-r1 )"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/sasl/md5global.h
+)
+
+PATCHES=(
+ "${WORKDIR}"/${MY_PATCH_VER}/
+)
+
+src_prepare() {
+ default
+
+ # Use plugindir for sasldir
+ # https://github.com/cyrusimap/cyrus-sasl/issues/339 (I think)
+ sed -i '/^sasldir =/s:=.*:= $(plugindir):' \
+ "${S}"/plugins/Makefile.{am,in} || die "sed failed"
+
+ # bug #486740 and bug #468556 (dropped AM_CONFIG_HEADER sed in 2.1.28)
+ sed -i -e 's:AC_CONFIG_MACRO_DIR:AC_CONFIG_MACRO_DIRS:g' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ export CC_FOR_BUILD="$(tc-getBUILD_CC)"
+
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/894684
+ # https://github.com/cyrusimap/cyrus-sasl/pull/771
+ #
+ # Fixed upstream in git master but not released.
+ use srp && filter-lto
+
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # getpassphrase is defined in /usr/include/stdlib.h
+ append-cppflags -DHAVE_GETPASSPHRASE
+ else
+ # this horrendously breaks things on Solaris
+ append-cppflags -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED -D_BSD_SOURCE -DLDAP_DEPRECATED
+ # replaces BSD_SOURCE (bug #579218)
+ append-cppflags -D_DEFAULT_SOURCE
+ fi
+
+ multilib-minimal_src_configure
+
+ if ( use berkdb || use gdbm ) && tc-is-cross-compiler ; then
+ mkdir -p "${WORKDIR}"/${P}-build || die
+ cd "${WORKDIR}"/${P}-build || die
+ # We don't care which berkdb version is used as this build is only
+ # temporary for generating an empty sasldb2 later.
+ ECONF_SOURCE="${S}" econf_build \
+ --with-dblib=$(usex berkdb berkeley gdbm)
+ fi
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-login
+ --enable-ntlm
+ --enable-auth-sasldb
+ --disable-cmulocal
+ --disable-krb4
+ --disable-macos-framework
+ --enable-otp
+ --without-sqlite
+ --with-saslauthd="${EPREFIX}"/run/saslauthd
+ --with-pwcheck="${EPREFIX}"/run/saslauthd
+ --with-configdir="${EPREFIX}"/etc/sasl2
+ --with-plugindir="${EPREFIX}/usr/$(get_libdir)/sasl2"
+ --with-dbpath="${EPREFIX}"/etc/sasl2/sasldb2
+ --with-sphinx-build=no
+ $(use_with ssl openssl)
+ $(use_with pam)
+ $(use_with openldap ldap)
+ $(use_enable ldapdb)
+ $(multilib_native_use_enable sample)
+ $(use_enable kerberos gssapi)
+ $(multilib_native_use_with mysql mysql "${EPREFIX}"/usr)
+ $(multilib_native_use_with postgres pgsql "${EPREFIX}/usr/$(get_libdir)/postgresql")
+ $(use_with sqlite sqlite3 "${EPREFIX}/usr/$(get_libdir)")
+ $(use_enable srp)
+ $(use_enable static-libs static)
+
+ # Add authdaemond support (bug #56523).
+ $(usex authdaemond --with-authdaemond="${EPREFIX}"/var/lib/courier/authdaemon/socket '')
+
+ # Fix for bug #59634.
+ $(usex ssl '' --without-des)
+
+ # Use /dev/urandom instead of /dev/random (bug #46038).
+ $(usex urandom --with-devrandom=/dev/urandom '')
+ )
+
+ if use sqlite || { multilib_is_native_abi && { use mysql || use postgres; }; } ; then
+ myeconfargs+=( --enable-sql )
+ else
+ myeconfargs+=( --disable-sql )
+ fi
+
+ # Default to GDBM if both 'gdbm' and 'berkdb' are present.
+ if use gdbm ; then
+ einfo "Building with GNU DB as database backend for your SASLdb"
+ myeconfargs+=( --with-dblib=gdbm )
+ elif use berkdb ; then
+ einfo "Building with BerkeleyDB as database backend for your SASLdb"
+ myeconfargs+=(
+ --with-dblib=berkeley
+ --with-bdb-incdir="$(db_includedir)"
+ )
+ else
+ einfo "Building without SASLdb support"
+ myeconfargs+=( --with-dblib=none )
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ multilib-minimal_src_compile
+
+ if ( use berkdb || use gdbm ) && tc-is-cross-compiler ; then
+ emake -C "${WORKDIR}"/${P}-build
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi; then
+ if use sample ; then
+ docinto sample
+ dodoc "${S}"/sample/*.c
+ exeinto /usr/share/doc/${P}/sample
+ doexe sample/client sample/server
+ fi
+
+ dosbin saslauthd/testsaslauthd
+ keepdir /etc/sasl2
+
+ if use berkdb || use gdbm ; then
+ einfo "Generating an empty sasldb2 ..."
+ tc-is-cross-compiler && { cd "${WORKDIR}"/${P}-build || die; }
+ export SASL_PATH=./plugins/.libs
+
+ ./utils/saslpasswd2 -f "${ED}"/etc/sasl2/sasldb2-empty -p login <<< p \
+ || die "Failed to generate sasldb2"
+
+ ./utils/saslpasswd2 -f "${ED}"/etc/sasl2/sasldb2-empty -d login \
+ || die "Failed to delete temp user"
+
+ fowners root:mail /etc/sasl2/sasldb2-empty
+ fperms 0640 /etc/sasl2/sasldb2-empty
+ fi
+ fi
+}
+
+multilib_src_install_all() {
+ doman man/*
+
+ # Reset docinto to default value (bug #674296)
+ docinto
+ dodoc AUTHORS ChangeLog doc/legacy/TODO
+ newdoc pwcheck/README README.pwcheck
+
+ newdoc docsrc/sasl/release-notes/$(ver_cut 1-2)/index.rst release-notes
+ edos2unix "${ED}"/usr/share/doc/${PF}/release-notes
+
+ docinto html
+ dodoc doc/html/*.html
+
+ if use pam; then
+ newpamd "${FILESDIR}"/saslauthd.pam-include saslauthd
+ fi
+
+ newinitd "${FILESDIR}"/pwcheck.rc6 pwcheck
+ systemd_dounit "${FILESDIR}"/pwcheck.service
+
+ newinitd "${FILESDIR}"/saslauthd2.rc7 saslauthd
+ newconfd "${FILESDIR}"/saslauthd-${SASLAUTHD_CONF_VER}.conf saslauthd
+ systemd_dounit "${FILESDIR}"/saslauthd.service
+ dotmpfiles "${FILESDIR}"/${PN}.conf
+
+ # The get_modname bit is important: do not remove the .la files on
+ # platforms where the lib isn't called .so for cyrus searches the .la to
+ # figure out what the name is supposed to be instead
+ if ! use static-libs && [[ $(get_modname) == .so ]] ; then
+ find "${ED}" -name "*.la" -delete || die
+ fi
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
+ if ( use berkdb || use gdbm ) && [[ ! -f ${EROOT}/etc/sasl2/sasldb2 ]] ; then
+ cp -av "${EROOT}"/etc/sasl2/sasldb2{-empty,} || die
+ fi
+
+ if use authdaemond ; then
+ elog "You need to add a user running a service using Courier's"
+ elog "authdaemon to the 'mail' group. For example, do:"
+ elog " gpasswd -a postfix mail"
+ elog "to add the 'postfix' user to the 'mail' group."
+ fi
+
+ elog "pwcheck and saslauthd home directories have moved to:"
+ elog " /run/saslauthd, using tmpfiles.d"
+}