summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-03-11 19:04:38 -0800
committerMike Frysinger <vapier@gentoo.org>2017-03-11 19:59:56 -0800
commit51b1dc0bf1515ef6d2e8d05b02cd9f980d3f9fac (patch)
tree2ec5dfe533063734edd7fa934b7f3f9d3c9eca8e /dev-libs/efl/efl-9999.ebuild
parentdev-libs/efl: add USE=unwind to control libunwind dep #611108 (diff)
downloadgentoo-51b1dc0bf1515ef6d2e8d05b02cd9f980d3f9fac.tar.gz
gentoo-51b1dc0bf1515ef6d2e8d05b02cd9f980d3f9fac.tar.bz2
gentoo-51b1dc0bf1515ef6d2e8d05b02cd9f980d3f9fac.zip
dev-libs/efl: version bump to 1.18.4 #591858
Diffstat (limited to 'dev-libs/efl/efl-9999.ebuild')
-rw-r--r--dev-libs/efl/efl-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-libs/efl/efl-9999.ebuild b/dev-libs/efl/efl-9999.ebuild
index e051bea2d47c..609840b2c5b1 100644
--- a/dev-libs/efl/efl-9999.ebuild
+++ b/dev-libs/efl/efl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -11,10 +11,9 @@ if [[ "${PV}" == "9999" ]] ; then
elif [[ *"${PV}" == *"_pre"* ]] ; then
MY_P=${P%%_*}
SRC_URI="https://download.enlightenment.org/pre-releases/${MY_P}.tar.xz"
- EKEY_STATE="snap"
else
SRC_URI="https://download.enlightenment.org/rel/libs/${PN}/${MY_P}.tar.xz"
- EKEY_STATE="snap"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
fi
inherit enlightenment pax-utils
@@ -22,7 +21,7 @@ inherit enlightenment pax-utils
DESCRIPTION="Enlightenment Foundation Libraries all-in-one package"
LICENSE="BSD-2 GPL-2 LGPL-2.1 ZLIB"
-IUSE="+bmp debug drm +eet egl fbcon +fontconfig fribidi gif gles glib gnutls gstreamer harfbuzz +ico ibus jpeg2k libressl neon oldlua opengl ssl physics pixman +png +ppm +psd pulseaudio raw scim sdl sound systemd tga tiff tslib unwind v4l valgrind wayland webp X xim xine xpm"
+IUSE="+bmp debug drm +eet egl fbcon +fontconfig fribidi gif gles glib gnutls gstreamer harfbuzz +ico ibus jpeg2k libressl neon oldlua opengl ssl physics pixman +png postscript +ppm +psd pulseaudio raw scim sdl sound systemd tga tiff tslib unwind v4l valgrind wayland webp X xim xine xpm"
REQUIRED_USE="
pulseaudio? ( sound )
@@ -64,6 +63,7 @@ RDEPEND="
oldlua? ( dev-lang/lua:* )
physics? ( >=sci-physics/bullet-2.80 )
pixman? ( x11-libs/pixman )
+ postscript? ( app-text/libspectre )
png? ( media-libs/libpng:0= )
pulseaudio? ( media-sound/pulseaudio )
raw? ( media-libs/libraw )
@@ -129,9 +129,12 @@ RDEPEND="
!dev-libs/eobj
!dev-libs/ephysics
!media-libs/edje
+ !media-libs/elementary
!media-libs/emotion
!media-libs/ethumb
!media-libs/evas
+ !media-plugins/emotion_generic_players
+ !media-plugins/evas_generic_loaders
"
#external lz4 support currently broken because of unstable ABI/API
# app-arch/lz4
@@ -230,6 +233,7 @@ src_configure() {
$(use_enable pixman pixman-image)
$(use_enable pixman pixman-image-scale-sample)
$(use_enable png image-loader-png)
+ $(use_enable postscript spectre)
$(use_enable ppm image-loader-pmaps)
$(use_enable psd image-loader-psd)
$(use_enable pulseaudio)