summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/engine_pkcs11
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/engine_pkcs11')
-rw-r--r--dev-libs/engine_pkcs11/Manifest1
-rw-r--r--dev-libs/engine_pkcs11/engine_pkcs11-0.1.8.ebuild47
-rw-r--r--dev-libs/engine_pkcs11/metadata.xml8
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/engine_pkcs11/Manifest b/dev-libs/engine_pkcs11/Manifest
new file mode 100644
index 000000000000..962a2e0d6aea
--- /dev/null
+++ b/dev-libs/engine_pkcs11/Manifest
@@ -0,0 +1 @@
+DIST engine_pkcs11-0.1.8.tar.gz 320799 SHA256 de7d7e41e7c42deef40c53e10ccc3f88d2c036d6656ecee7e82e8be07b06a2e5 SHA512 00fa7cf1e44544267248b17669f69a3d91b8e3008da8a8d70004d8ed87543eb75b06c4a9f028f9aee157f54110acadf40d2c6ff3835eae4cf0c29ac819557dc2 WHIRLPOOL c2121466980c9fb425e1f6ca53dde2b055fa833c3f42494dc2fc6f7a0468aa84d14cacc1ff2bd8319f54eb336ae79b3b442f33406ff275074162e1b274beff7a
diff --git a/dev-libs/engine_pkcs11/engine_pkcs11-0.1.8.ebuild b/dev-libs/engine_pkcs11/engine_pkcs11-0.1.8.ebuild
new file mode 100644
index 000000000000..46b1e8218963
--- /dev/null
+++ b/dev-libs/engine_pkcs11/engine_pkcs11-0.1.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit autotools subversion
+ ESVN_REPO_URI="http://www.opensc-project.org/svn/${PN}/trunk"
+else
+ SRC_URI="http://www.opensc-project.org/files/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="engine_pkcs11 is an implementation of an engine for OpenSSL"
+HOMEPAGE="http://www.opensc-project.org/engine_pkcs11"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libp11-0.2.5
+ >=dev-libs/openssl-0.9.7d:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+if [[ "${PV}" = "9999" ]]; then
+ DEPEND="${DEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt"
+
+ src_prepare() {
+ eautoreconf
+ }
+fi
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --htmldir="/usr/share/doc/${PF}/html" \
+ --disable-static --enable-shared \
+ --enable-doc
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+}
diff --git a/dev-libs/engine_pkcs11/metadata.xml b/dev-libs/engine_pkcs11/metadata.xml
new file mode 100644
index 000000000000..9682e47bb258
--- /dev/null
+++ b/dev-libs/engine_pkcs11/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <longdescription>
+ engine_pkcs11 is an implementation of an engine for OpenSSL.
+ </longdescription>
+</pkgmetadata>