summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-08-10 10:40:15 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-08-10 10:40:15 +0300
commit3a7a950375b06bd34c861de68c1d67612741c912 (patch)
treefb6ef860e871a535b8d32f6a9fa3ec45798c2e0b /dev-libs/foma/foma-0.10.0_p20220612.ebuild
parentapp-text/mupdf: Stabilize 1.20.0 x86, #864507 (diff)
downloadgentoo-3a7a950375b06bd34c861de68c1d67612741c912.tar.gz
gentoo-3a7a950375b06bd34c861de68c1d67612741c912.tar.bz2
gentoo-3a7a950375b06bd34c861de68c1d67612741c912.zip
dev-libs/foma: add 0.10.0_p20220612
Closes: https://bugs.gentoo.org/722948 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/foma/foma-0.10.0_p20220612.ebuild')
-rw-r--r--dev-libs/foma/foma-0.10.0_p20220612.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/foma/foma-0.10.0_p20220612.ebuild b/dev-libs/foma/foma-0.10.0_p20220612.ebuild
new file mode 100644
index 000000000000..eeada44575e2
--- /dev/null
+++ b/dev-libs/foma/foma-0.10.0_p20220612.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_COMMIT="9e8c3df573015a26c84e113ba710ef3d57c8e777"
+
+DESCRIPTION="Multi-purpose finite-state toolkit"
+HOMEPAGE="https://fomafst.github.io/ https://github.com/mhulden/foma"
+SRC_URI="https://github.com/mhulden/foma/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/0.10"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-devel/bison
+ sys-devel/flex"
+DEPEND="sys-libs/readline:=
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/foma-${MY_COMMIT}/foma"
+
+src_install() {
+ cmake_src_install
+ find "${D}" -name '*.a' -delete || die
+}