summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-18 22:47:05 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-18 22:51:47 -0400
commit4ae9bd0b6b3ecae0d7ff8c9a9748d15e34658eb7 (patch)
tree3a8cd47dcee2908463a8d7277162b92c537dec9e /dev-libs/fstrm/fstrm-0.3.0.ebuild
parentapp-misc/when: version bump to 1.1.36 (diff)
downloadgentoo-4ae9bd0b6b3ecae0d7ff8c9a9748d15e34658eb7.tar.gz
gentoo-4ae9bd0b6b3ecae0d7ff8c9a9748d15e34658eb7.tar.bz2
gentoo-4ae9bd0b6b3ecae0d7ff8c9a9748d15e34658eb7.zip
dev-libs/fstrm: version bump to 0.3.0
Diffstat (limited to 'dev-libs/fstrm/fstrm-0.3.0.ebuild')
-rw-r--r--dev-libs/fstrm/fstrm-0.3.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/fstrm/fstrm-0.3.0.ebuild b/dev-libs/fstrm/fstrm-0.3.0.ebuild
new file mode 100644
index 000000000000..d37861de839a
--- /dev/null
+++ b/dev-libs/fstrm/fstrm-0.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools multilib-minimal
+
+DESCRIPTION="Frame Streams implementation in C"
+HOMEPAGE="https://github.com/farsightsec/fstrm"
+SRC_URI="https://github.com/farsightsec/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="static-libs utils"
+
+RDEPEND="utils? ( dev-libs/libevent[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+src_prepare() {
+ default
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable utils programs)
+}
+
+multilib_src_install_all() {
+ default
+ find "${ED}" -name '*.la' -delete
+}