summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-09-18 18:49:55 +0300
committerMart Raudsepp <leio@gentoo.org>2021-09-18 19:05:22 +0300
commita08412dce8f6c05ad0d44d7e62b20447d801bc5e (patch)
treee91c469190b980c74f571987e82c2e6074e43cf0 /dev-libs/gobject-introspection-common/gobject-introspection-common-1.70.0.ebuild
parentsci-geosciences/gnome-maps: bump to 40.5 (diff)
downloadgentoo-a08412dce8f6c05ad0d44d7e62b20447d801bc5e.tar.gz
gentoo-a08412dce8f6c05ad0d44d7e62b20447d801bc5e.tar.bz2
gentoo-a08412dce8f6c05ad0d44d7e62b20447d801bc5e.zip
dev-libs/gobject-introspection-common: bump to 1.70.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/gobject-introspection-common/gobject-introspection-common-1.70.0.ebuild')
-rw-r--r--dev-libs/gobject-introspection-common/gobject-introspection-common-1.70.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection-common/gobject-introspection-common-1.70.0.ebuild b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.70.0.ebuild
new file mode 100644
index 000000000000..ff6157de2f64
--- /dev/null
+++ b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.70.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="gobject-introspection"
+
+inherit gnome.org
+
+DESCRIPTION="Build infrastructure for GObject Introspection"
+HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!<${CATEGORY}/${GNOME_ORG_MODULE}-${PV}"
+# Use !<${PV} because mixing gobject-introspection with different version of -common can cause issues like:
+# https://forums.gentoo.org/viewtopic-p-7421930.html
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/aclocal
+ doins m4/introspection.m4
+
+ insinto /usr/share/gobject-introspection-1.0
+ doins Makefile.introspection
+}