summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-03-22 11:06:22 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-22 11:06:22 +0100
commita4484fc63431d84fd0b366557d1c8a5df964d1c0 (patch)
treec63acece08f7cc547ca30b22b7d06cd699b3676a /dev-libs/icu
parentdev-vcs/git: move Emacs to BDEPEND (diff)
downloadgentoo-a4484fc63431d84fd0b366557d1c8a5df964d1c0.tar.gz
gentoo-a4484fc63431d84fd0b366557d1c8a5df964d1c0.tar.bz2
gentoo-a4484fc63431d84fd0b366557d1c8a5df964d1c0.zip
dev-libs/icu: work around cross-endian tests failing
The tests need __USE_MISC, which is undefined by -std=c11, which is added by --enable-strict, which is the default setting. There are fallback tests that work for native builds and non-LTO builds, but this specific case has no fallback and requires this workaround. Closes: https://bugs.gentoo.org/757681 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/icu')
-rw-r--r--dev-libs/icu/icu-68.2.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-libs/icu/icu-68.2.ebuild b/dev-libs/icu/icu-68.2.ebuild
index 9f6649c9de0e..1b834bbdc0ca 100644
--- a/dev-libs/icu/icu-68.2.ebuild
+++ b/dev-libs/icu/icu-68.2.ebuild
@@ -91,6 +91,11 @@ multilib_src_configure() {
--with-cross-build="${WORKDIR}"/host
)
+ # work around cross-endian testing failures with LTO #757681
+ if tc-is-cross-compiler && is-flagq '-flto*' ; then
+ myeconfargs+=( --disable-strict )
+ fi
+
# icu tries to use clang by default
tc-export CC CXX