summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-10-03 15:32:24 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-10-03 16:24:56 +0200
commite3aca393bbb47e025f2cf25ab07cc2205a9a6465 (patch)
tree7fec3f8f0c318510a7aa81d4f7269c7c4d0483f1 /dev-libs/intel-compute-runtime
parentdev-python/watchdog: Remove old (diff)
downloadgentoo-e3aca393bbb47e025f2cf25ab07cc2205a9a6465.tar.gz
gentoo-e3aca393bbb47e025f2cf25ab07cc2205a9a6465.tar.bz2
gentoo-e3aca393bbb47e025f2cf25ab07cc2205a9a6465.zip
dev-libs/intel-neo: rename to dev-libs/intel-compute-runtime
This renames intel-neo to the proper upstream name, which every other distribution is using. Closes: https://github.com/gentoo/gentoo/pull/22475 Closes: https://bugs.gentoo.org/815184 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest3
-rw-r--r--dev-libs/intel-compute-runtime/files/intel-compute-runtime-21.31.20514-no_Werror.patch10
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-21.33.20678-r1.ebuild61
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-21.37.20939.ebuild61
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-21.38.21026.ebuild61
-rw-r--r--dev-libs/intel-compute-runtime/metadata.xml34
6 files changed, 230 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
new file mode 100644
index 000000000000..21fd889e64cb
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -0,0 +1,3 @@
+DIST intel-compute-runtime-21.33.20678.tar.gz 4534884 BLAKE2B 9a5e7f962be08701bec1e890eeb5b6208694a33b524872494e428b73d46629b7cde1522c6b7d0b27725cc170f1e65391892b253ca84d988b209e41631548b135 SHA512 278284fafe0e2d340668e1c21188b706ab48439c6ea573885d1b060df458e2016ed40e0a0c65e4076378ddb3ab284eb2cd92b1db5e6bd892babf2275ed600341
+DIST intel-compute-runtime-21.37.20939.tar.gz 4576917 BLAKE2B 42563ce897667025100b40f504fe4897222fd28f1b82ac22fb6cfaa6a273b8e9199d57743ab338ab52b32c9598bbf6856530688ca9cbff360db356dabed6d96b SHA512 ed213e2fd234300ac940ffa503a34ae54698e2d359927b3bdcb59bf7ea9d6b950073e9e2e750ec5b8e3e387f0c8d74b4852627c283964fd6a9742dcdc32f518f
+DIST intel-compute-runtime-21.38.21026.tar.gz 4655853 BLAKE2B 28ebfb1cbce30fdefb7104a2b6840ea95d62645ae51a97a0b970aa4344fca7e64eb8f289895c30cf9fe4a0d9e5294490810236c0e565e78383ad7096429e2155 SHA512 08ffaaed80ef5776e6ecff15467170ca143887cda7905a49f7b2d12862ff17e75e7ff89ff2bb76ce25eec4ef32dfc882ac3cddf5a3e71d24adb21cc8c806cf5b
diff --git a/dev-libs/intel-compute-runtime/files/intel-compute-runtime-21.31.20514-no_Werror.patch b/dev-libs/intel-compute-runtime/files/intel-compute-runtime-21.31.20514-no_Werror.patch
new file mode 100644
index 000000000000..bd77b7c4e9ab
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/files/intel-compute-runtime-21.31.20514-no_Werror.patch
@@ -0,0 +1,10 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -868,7 +868,6 @@
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-noexcept-type") # Added for gtest
+ endif()
+ endif()
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
+
+ if(USE_SANITIZE_UB)
+ check_cxx_compiler_flag(-fsanitize=undefined COMPILER_SUPPORTS_UNDEFINED_BEHAVIOR_SANITIZER)
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-21.33.20678-r1.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.33.20678-r1.ebuild
new file mode 100644
index 000000000000..331420e21856
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.33.20678-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND="
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.8365
+ dev-util/intel-graphics-system-controller
+ >=media-libs/gmmlib-21.2.1
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.4.1 )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+# for Khronos OpenGL headers
+DEPEND="
+ ${RDEPEND}
+ media-libs/mesa
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-21.31.20514-no_Werror.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="ON"
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-21.37.20939.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.37.20939.ebuild
new file mode 100644
index 000000000000..6095fe8dcf3b
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.37.20939.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND="
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.8517-r1
+ >=dev-util/intel-graphics-system-controller-0.2.3
+ >=media-libs/gmmlib-21.2.1
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.4.1 )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+# for Khronos OpenGL headers
+DEPEND="
+ ${RDEPEND}
+ media-libs/mesa
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-21.31.20514-no_Werror.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="ON"
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-21.38.21026.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.38.21026.ebuild
new file mode 100644
index 000000000000..246811d9d9c7
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.38.21026.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND="
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.8708
+ >=dev-util/intel-graphics-system-controller-0.2.4
+ >=media-libs/gmmlib-21.2.1
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.5.0 )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+# for Khronos OpenGL headers
+DEPEND="
+ ${RDEPEND}
+ media-libs/mesa
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-21.31.20514-no_Werror.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="ON"
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-libs/intel-compute-runtime/metadata.xml b/dev-libs/intel-compute-runtime/metadata.xml
new file mode 100644
index 000000000000..276e8daabc8a
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>gentoo@taujhe.de</email>
+ <name>Jan Henke</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ The Intel Graphics Compute Runtime for for oneAPI Level Zero and
+ OpenCL Driver, informally known as NEO, is an open source project providing
+ compute API support (Level Zero, OpenCL) for Intel graphics hardware
+ architectures (HD Graphics, Xe).
+ For OpenCL, NEO supports Intel Core processors with Gen8 graphics devices
+ (Broadwell architecture) and newer, as well as Intel Atom processors with Gen9
+ graphics devices (Apollo Lake, Gemini Lake).
+ Level Zero support is more limited and as of April 2020 still in early stages,
+ please consult upstream release notices for details.
+ </longdescription>
+ <use>
+ <flag name="l0">Install the oneAPI Level Zero driver alongside the OpenCL one</flag>
+ <flag name="vaapi">Support the sharing of surfaces with Video Acceleration API (OpenCL Extension #36)</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">intel/compute-runtime</remote-id>
+ </upstream>
+</pkgmetadata>