summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-14 10:50:49 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-17 22:28:45 -0400
commit3c945a6c8a19c11e5fd332160f6546e70c813365 (patch)
tree4af7b547e887162c526daaf360ed68ee44818d02 /dev-libs/jsonrpc-glib
parentwww-servers/h2o: update USE_RUBY (diff)
downloadgentoo-3c945a6c8a19c11e5fd332160f6546e70c813365.tar.gz
gentoo-3c945a6c8a19c11e5fd332160f6546e70c813365.tar.bz2
gentoo-3c945a6c8a19c11e5fd332160f6546e70c813365.zip
dev-libs/jsonrpc-glib: Version bump to 3.44.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/jsonrpc-glib')
-rw-r--r--dev-libs/jsonrpc-glib/Manifest1
-rw-r--r--dev-libs/jsonrpc-glib/jsonrpc-glib-3.44.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/jsonrpc-glib/Manifest b/dev-libs/jsonrpc-glib/Manifest
index d968af50bdc9..3a9a92ed4380 100644
--- a/dev-libs/jsonrpc-glib/Manifest
+++ b/dev-libs/jsonrpc-glib/Manifest
@@ -1 +1,2 @@
DIST jsonrpc-glib-3.42.0.tar.xz 42420 BLAKE2B a60ebebfee652ea694cd2884e057522534826cbca506d04847d29a23dd3035e9a1043912c9a434d4b8b58a6fcb91ba05cc8c76cf380e6205f3d89f9387800bf6 SHA512 615e446dba2b1bbefe1bf8891449de9d39e3486fefda590781f59469ea50e6affa487bcb260bd3e21ca30e696b1dec7a761c8d93ec9c0894d9bb4c3d65f106dc
+DIST jsonrpc-glib-3.44.0.tar.xz 42580 BLAKE2B 7a72aefc092eb0a17c6935323e9157c7bc07cfec766ede11c369651da95b5ff77ead09977f38b7c91b4bbcd04e7adb81d95e9eefe976f739502c1720a477efec SHA512 85962af18cb62af7c4dfa37289cf53ba9c905ee00994cc6bcc2679f1e0f79ea0b134386179dd2417e6166777d65f025959d6d258aa279bbfb1f4cacceeede7af
diff --git a/dev-libs/jsonrpc-glib/jsonrpc-glib-3.44.0.ebuild b/dev-libs/jsonrpc-glib/jsonrpc-glib-3.44.0.ebuild
new file mode 100644
index 000000000000..87b915ae6bf9
--- /dev/null
+++ b/dev-libs/jsonrpc-glib/jsonrpc-glib-3.44.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala
+
+DESCRIPTION="JSON-RPC library for GLib"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/jsonrpc-glib"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk-doc +introspection test vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib[introspection?]
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ vala? ( $(vala_depend) )
+ dev-util/glib-utils
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gi-docgen )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denable_profiling=false # -pg passing
+ $(meson_use introspection with_introspection)
+ $(meson_use vala with_vapi)
+ $(meson_use gtk-doc enable_gtk_doc)
+ $(meson_use test enable_tests)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}