summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-10-03 23:54:57 +0200
committerMichał Górny <mgorny@gentoo.org>2017-10-04 00:12:22 +0200
commitaab37023f705b100c60a118362ff20236970ad6e (patch)
tree76632c38cb2e0c97b75715e481baf450e11daab6 /dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
parentgames-fps/warsow: Remove last-rited pkg (diff)
downloadgentoo-aab37023f705b100c60a118362ff20236970ad6e.tar.gz
gentoo-aab37023f705b100c60a118362ff20236970ad6e.tar.bz2
gentoo-aab37023f705b100c60a118362ff20236970ad6e.zip
dev-libs/libRocket: Remove last-rited pkg
Closes: https://bugs.gentoo.org/558698 Closes: https://bugs.gentoo.org/599224 Closes: https://bugs.gentoo.org/600680
Diffstat (limited to 'dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild')
-rw-r--r--dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild96
1 files changed, 0 insertions, 96 deletions
diff --git a/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild b/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
deleted file mode 100644
index 9d21accbda41..000000000000
--- a/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils eutils python-r1 multilib-minimal
-
-DESCRIPTION="A HTML/CSS User Interface library"
-HOMEPAGE="https://librocket.com/"
-SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="python samples"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- >=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]
- python? (
- ${PYTHON_DEPS}
- dev-libs/boost[${PYTHON_USEDEP}]
- )
- samples? (
- virtual/opengl
- x11-libs/libXext
- x11-libs/libX11
- )"
-DEPEND="${RDEPEND}"
-
-DOCS=( changelog.txt readme.md )
-
-python_BUILD_DIR=${WORKDIR}/${P}_build_python
-CMAKE_USE_DIR="${S}"/Build
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DBUILD_PYTHON_BINDINGS=OFF
- -DSAMPLES_DIR=/usr/share/${PN}/samples
- )
-
- if multilib_is_native_abi ; then
- mycmakeargs+=( $(cmake-utils_use_build samples SAMPLES) )
- else
- mycmakeargs+=( -DBUILD_SAMPLES=OFF )
- fi
-
- cmake-utils_src_configure
-
- if multilib_is_native_abi ; then
- if use python ; then
- cfgpybind() {
- local mycmakeargs=(
- -DBUILD_PYTHON_BINDINGS=ON
- -DCMAKE_SKIP_RPATH=YES
- )
- BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_configure
- }
- einfo "configuring python binding"
- python_foreach_impl cfgpybind
- fi
- fi
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
- local abi_build_dir=${BUILD_DIR}
-
- if multilib_is_native_abi ; then
- if use python ; then
- buildpybind() {
- cp "${abi_build_dir}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
- BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_make _rocketcontrols/fast _rocketcore/fast
- }
- einfo "compiling python binding"
- python_foreach_impl buildpybind
- fi
- fi
-}
-
-multilib_src_install() {
- cmake-utils_src_install
-
- if multilib_is_native_abi ; then
- if use python ; then
- instpybind() {
- python_domodule "${S}"/bin/rocket.py
- exeinto "$(python_get_sitedir)"
- doexe ${python_BUILD_DIR}-${EPYTHON}/_rocket{core,controls}.so
- }
- einfo "installing python binding"
- python_foreach_impl instpybind
- fi
- fi
-}