summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-10 11:47:12 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-10 13:42:56 +0100
commit7d11bcf35e2a17deeb6dd6a0ac31ccae98fc313f (patch)
treee90c8761300b0aaa56e5f126bffe5ef767e67f81 /dev-libs/libb64/libb64-2.0.0.1.ebuild
parentsys-libs/librtas-2.0.2-r1: fix install for Prefix (diff)
downloadgentoo-7d11bcf35e2a17deeb6dd6a0ac31ccae98fc313f.tar.gz
gentoo-7d11bcf35e2a17deeb6dd6a0ac31ccae98fc313f.tar.bz2
gentoo-7d11bcf35e2a17deeb6dd6a0ac31ccae98fc313f.zip
dev-libs/libb64: Bump to 2.0.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libb64/libb64-2.0.0.1.ebuild')
-rw-r--r--dev-libs/libb64/libb64-2.0.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libb64/libb64-2.0.0.1.ebuild b/dev-libs/libb64/libb64-2.0.0.1.ebuild
new file mode 100644
index 000000000000..9adbb345b334
--- /dev/null
+++ b/dev-libs/libb64/libb64-2.0.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Fast Base64 encoding/decoding routines"
+HOMEPAGE="https://github.com/libb64/libb64/"
+SRC_URI="
+ https://github.com/libb64/libb64/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC-PD"
+# static library, so always rebuild
+SLOT="0/${PVR}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+src_compile() {
+ # override -O3, -Werror non-sense
+ emake -C src CFLAGS="${CFLAGS} -I../include"
+}
+
+src_install() {
+ dolib.a src/libb64.a
+ insinto /usr/include
+ doins -r include/b64
+ einstalldocs
+}