summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-08-12 12:47:06 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2017-08-12 12:49:39 -0700
commit99a0c54af8f1af1ce9a7db8d99d595276ccb581c (patch)
tree791349fd99f82961aa2129075200cd1eb14406ad /dev-libs/libclc
parentapp-admin/rsyslog: x86 & amd64 stable (diff)
downloadgentoo-99a0c54af8f1af1ce9a7db8d99d595276ccb581c.tar.gz
gentoo-99a0c54af8f1af1ce9a7db8d99d595276ccb581c.tar.bz2
gentoo-99a0c54af8f1af1ce9a7db8d99d595276ccb581c.zip
dev-libs/libclc: fix llvm-config path.
clang path can be ccache-based, but llvm-config is not hooked by ccache, so find it better ourselves. Closes: https://bugs.gentoo.org/show_bug.cgi?id=624034 Package-Manager: portage-2.3.6 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-libs/libclc')
-rw-r--r--dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild6
1 files changed, 1 insertions, 5 deletions
diff --git a/dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild b/dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild
index c0ac06980cb4..003757a0998e 100644
--- a/dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild
+++ b/dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild
@@ -39,13 +39,9 @@ DEPEND="${RDEPEND}
${PYTHON_DEPS}"
src_configure() {
- # we need to find llvm with matching clang version, so look for
- # clang first, and then use llvm-config from the same location
- local clang_path=$(type -P clang) || die
-
./configure.py \
--with-cxx-compiler="$(tc-getCXX)" \
- --with-llvm-config="${clang_path%/*}/llvm-config" \
+ --with-llvm-config="$(tc-getPROG LLVM_CONFIG llvm-config)" \
--prefix="${EPREFIX}/usr" || die
}