summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-11-30 19:35:52 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-11-30 20:05:25 +0100
commitd1b12df8b8755c31cf1c6a871882697f7ba8c0b9 (patch)
tree7c30258d426983fddf4ae0ecb3ead2a9828ed3e8 /dev-libs/libfilezilla/libfilezilla-0.11.1.ebuild
parentdev-libs/libdbusmenu-qt: x86 stable (bug #638276) (diff)
downloadgentoo-d1b12df8b8755c31cf1c6a871882697f7ba8c0b9.tar.gz
gentoo-d1b12df8b8755c31cf1c6a871882697f7ba8c0b9.tar.bz2
gentoo-d1b12df8b8755c31cf1c6a871882697f7ba8c0b9.zip
dev-libs/libfilezilla: Bump to version 0.11.1
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-libs/libfilezilla/libfilezilla-0.11.1.ebuild')
-rw-r--r--dev-libs/libfilezilla/libfilezilla-0.11.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libfilezilla/libfilezilla-0.11.1.ebuild b/dev-libs/libfilezilla/libfilezilla-0.11.1.ebuild
new file mode 100644
index 000000000000..31545f46bee8
--- /dev/null
+++ b/dev-libs/libfilezilla/libfilezilla-0.11.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="C++ library offering some basic functionality for platform-independent programs"
+HOMEPAGE="https://lib.filezilla-project.org/"
+SRC_URI="mirror://sourceforge/filezilla/${P}.tar.bz2
+ http://download.filezilla-project.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}