summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-13 18:24:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-13 18:24:36 +0100
commit2def68c8174a87ca27096c3718111be8c1c956a6 (patch)
tree28d1e3d751cf0244197e11edb8d9d1752dbf2d88 /dev-libs/libgit2
parentdev-python/aesara: Remove old (diff)
downloadgentoo-2def68c8174a87ca27096c3718111be8c1c956a6.tar.gz
gentoo-2def68c8174a87ca27096c3718111be8c1c956a6.tar.bz2
gentoo-2def68c8174a87ca27096c3718111be8c1c956a6.zip
dev-libs/libgit2: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libgit2')
-rw-r--r--dev-libs/libgit2/Manifest1
-rw-r--r--dev-libs/libgit2/libgit2-1.4.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-libs/libgit2/Manifest b/dev-libs/libgit2/Manifest
index 4f8bf13b9779..81e484183f9a 100644
--- a/dev-libs/libgit2/Manifest
+++ b/dev-libs/libgit2/Manifest
@@ -1 +1,2 @@
DIST libgit2-1.3.0.tar.gz 5599575 BLAKE2B b701c105bb0a5bdcdd5ed1db180662ad4949c540944664d5d8c2f5d78998f15d15bd3669ae3e3d43bfa1b81207c0a94b7e49fc76e57f4cc8ef791ab26e62fc70 SHA512 842a648a67ff23ba9e6bf14b706ba9081164866e14000ebf3858442b7046925f05e1dbf00a7d740dc4bf32280e260730e23a9492e817094aa90736ae335ee76e
+DIST libgit2-1.4.0.tar.gz 5628993 BLAKE2B b28795904250474e0a373bb28f18f0a18c17c91c1597ad56eb44f8d47a8cb0aa6521b0599f427f34e477771116929db8d5bcafcb7aaf97ddc2534dfa3fd89525 SHA512 e7eff2e30a299901d7b4d9544b655046801e5c83b0caf1d2476ab56c164c88448dc189b254929f2609e117f01c2e038c4538e7554269ad93fbd625229668cd06
diff --git a/dev-libs/libgit2/libgit2-1.4.0.ebuild b/dev-libs/libgit2/libgit2-1.4.0.ebuild
new file mode 100644
index 000000000000..a7e8b234e246
--- /dev/null
+++ b/dev-libs/libgit2/libgit2-1.4.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cmake python-any-r1
+
+DESCRIPTION="A linkable library for Git"
+HOMEPAGE="https://libgit2.org"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${P/_/-}
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~ppc-macos"
+IUSE="examples gssapi +ssh test +threads trace"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libpcre:=
+ net-libs/http-parser:=
+ sys-libs/zlib
+ dev-libs/openssl:0=
+ gssapi? ( virtual/krb5 )
+ ssh? ( net-libs/libssh2 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ cmake_src_prepare
+ # relying on forked http-parser to support some obscure URI form
+ sed -i -e '/empty_port/s:test:_&:' tests/network/url/parse.c || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_CLAR=$(usex test)
+ -DENABLE_TRACE=$(usex trace ON OFF)
+ -DUSE_GSSAPI=$(usex gssapi ON OFF)
+ -DUSE_SSH=$(usex ssh)
+ -DTHREADSAFE=$(usex threads)
+ -DUSE_HTTP_PARSER=system
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]] ; then
+ # repo::iterator::fs_preserves_error fails if run as root
+ # since root can still access dirs with 0000 perms
+ ewarn "Skipping tests: non-root privileges are required for all tests to pass"
+ else
+ local TEST_VERBOSE=1
+ cmake_src_test -R offline
+ fi
+}
+
+src_install() {
+ cmake_src_install
+ dodoc docs/*.{md,txt}
+
+ if use examples ; then
+ find examples -name '.gitignore' -delete || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}