summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-03 20:26:56 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-03 21:36:53 -0500
commita5f88593cb7bc702d70c76366fe2b44607e6e893 (patch)
tree86f3036b26877fe846228011b6fe024eda3a65ed /dev-libs/libgit2
parentdev-libs/libgee: Drop old versions (diff)
downloadgentoo-a5f88593cb7bc702d70c76366fe2b44607e6e893.tar.gz
gentoo-a5f88593cb7bc702d70c76366fe2b44607e6e893.tar.bz2
gentoo-a5f88593cb7bc702d70c76366fe2b44607e6e893.zip
dev-libs/libgit2: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libgit2')
-rw-r--r--dev-libs/libgit2/Manifest1
-rw-r--r--dev-libs/libgit2/libgit2-1.3.2.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-libs/libgit2/Manifest b/dev-libs/libgit2/Manifest
index e71d0db1db79..eaa20061cd72 100644
--- a/dev-libs/libgit2/Manifest
+++ b/dev-libs/libgit2/Manifest
@@ -1,2 +1 @@
-DIST libgit2-1.3.2.tar.gz 5824473 BLAKE2B 521512721d5959274898046e4341e000c3d0bb28cffde9c1c5f9640f73c74fb3b5330a2329b57a92490acd93f6b59f9b53d9940b50a1056c15f52632db9fdfe6 SHA512 580ad6f3e2cb992014d7fecef4d834dd0fda169c4439ec5d566322edb457b2173910b25a49ba50d5bd05518ad771ee2f42e47ab48ce417c297b6a93dd0cb502d
DIST libgit2-1.5.0.tar.gz 5893437 BLAKE2B 4108de0e8fc6a02e4172f47cb69cdfe8c85a0a72235432ca58b02d94e0bcb8390caf0c710060772551cc3a392291778ae14b561256c6d88058d0ae5a277f2fbf SHA512 7a32b27cd32bd03ce7be6c127317f82a4ac6f16615c3234699676781f4858d057edb0410b2fe36fd2e634b00748a8b0be17f23809e09a7602ba48185134300f7
diff --git a/dev-libs/libgit2/libgit2-1.3.2.ebuild b/dev-libs/libgit2/libgit2-1.3.2.ebuild
deleted file mode 100644
index 6b1791d917a0..000000000000
--- a/dev-libs/libgit2/libgit2-1.3.2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake python-any-r1
-
-DESCRIPTION="A linkable library for Git"
-HOMEPAGE="https://libgit2.org/"
-SRC_URI="
- https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
-"
-S=${WORKDIR}/${P/_/-}
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0/$(ver_cut 1-2)"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86 ~ppc-macos"
-IUSE="examples gssapi +ssh test +threads trace"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/libpcre:=
- net-libs/http-parser:=
- sys-libs/zlib
- dev-libs/openssl:0=
- gssapi? ( virtual/krb5 )
- ssh? ( net-libs/libssh2 )
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
-"
-
-src_prepare() {
- cmake_src_prepare
- # relying on forked http-parser to support some obscure URI form
- sed -i -e '/empty_port/s:test:_&:' tests/network/url/parse.c || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_CLAR=$(usex test)
- -DENABLE_TRACE=$(usex trace ON OFF)
- -DUSE_GSSAPI=$(usex gssapi ON OFF)
- -DUSE_SSH=$(usex ssh)
- -DTHREADSAFE=$(usex threads)
- -DUSE_HTTP_PARSER=system
- )
- cmake_src_configure
-}
-
-src_test() {
- if [[ ${EUID} -eq 0 ]] ; then
- # repo::iterator::fs_preserves_error fails if run as root
- # since root can still access dirs with 0000 perms
- ewarn "Skipping tests: non-root privileges are required for all tests to pass"
- else
- local TEST_VERBOSE=1
- cmake_src_test -R offline
- fi
-}
-
-src_install() {
- cmake_src_install
- dodoc docs/*.{md,txt}
-
- if use examples ; then
- find examples -name '.gitignore' -delete || die
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}