summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-05-10 11:30:05 -0400
committerMatt Turner <mattst88@gentoo.org>2023-05-10 11:30:17 -0400
commit1b50f4a5a00cb88c588cbaf8ea8bcbcbbae36190 (patch)
tree91e0cc4609e9bb3c5a6cd5c038cf25152a6d34ef /dev-libs/libwacom/libwacom-2.5.0.ebuild
parentdev-python/xcffib: Remove obsolete dep on dev-python/six (diff)
downloadgentoo-1b50f4a5a00cb88c588cbaf8ea8bcbcbbae36190.tar.gz
gentoo-1b50f4a5a00cb88c588cbaf8ea8bcbcbbae36190.tar.bz2
gentoo-1b50f4a5a00cb88c588cbaf8ea8bcbcbbae36190.zip
dev-libs/libwacom: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libwacom/libwacom-2.5.0.ebuild')
-rw-r--r--dev-libs/libwacom/libwacom-2.5.0.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/dev-libs/libwacom/libwacom-2.5.0.ebuild b/dev-libs/libwacom/libwacom-2.5.0.ebuild
deleted file mode 100644
index 62173377ae27..000000000000
--- a/dev-libs/libwacom/libwacom-2.5.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit meson python-any-r1 udev
-
-DESCRIPTION="Library for identifying Wacom tablets and their model-specific features"
-HOMEPAGE="https://github.com/linuxwacom/libwacom"
-SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0/9" # libwacom SONAME
-KEYWORDS="~alpha amd64 arm ~arm64 ~ia64 ppc ppc64 sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/glib:2
- dev-libs/libgudev:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep '
- dev-python/python-libevdev[${PYTHON_USEDEP}]
- dev-python/pyudev[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- ')
- )
-"
-
-python_check_deps() {
- python_has_version "dev-python/python-libevdev[${PYTHON_USEDEP}]" &&
- python_has_version "dev-python/pyudev[${PYTHON_USEDEP}]" &&
- python_has_version "dev-python/pytest[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- if use test; then
- python-any-r1_pkg_setup
- fi
-}
-
-src_prepare() {
- default
-
- # Don't call systemd daemon-reload in the test suite
- sed -i -e '/daemon-reload/d' test/test_udev_rules.py || die
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_feature doc documentation)
- $(meson_feature test tests)
- -Dudev-dir=$(get_udevdir)
- )
- meson_src_configure
-}
-
-pkg_postinst() {
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}