summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-03 04:32:45 +0000
committerSam James <sam@gentoo.org>2022-12-03 06:06:05 +0000
commit93cbfc9294406cbda0b93b6278a3c9a5344bae5b (patch)
treeb93b10805a3f4ae0757849181af2844f9e46d9bd /dev-libs/papi
parentsys-libs/obstack-standalone: Stabilize 1.2.3 x86, #867349 (diff)
downloadgentoo-93cbfc9294406cbda0b93b6278a3c9a5344bae5b.tar.gz
gentoo-93cbfc9294406cbda0b93b6278a3c9a5344bae5b.tar.bz2
gentoo-93cbfc9294406cbda0b93b6278a3c9a5344bae5b.zip
dev-libs/papi: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/papi')
-rw-r--r--dev-libs/papi/files/papi-6.0.0.1-configure-clang16.patch53
-rw-r--r--dev-libs/papi/papi-6.0.0.1-r1.ebuild (renamed from dev-libs/papi/papi-6.0.0.1.ebuild)6
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-libs/papi/files/papi-6.0.0.1-configure-clang16.patch b/dev-libs/papi/files/papi-6.0.0.1-configure-clang16.patch
new file mode 100644
index 000000000000..a56213cdb6d5
--- /dev/null
+++ b/dev-libs/papi/files/papi-6.0.0.1-configure-clang16.patch
@@ -0,0 +1,53 @@
+https://bitbucket.org/icl/papi/pull-requests/406
+
+From 3d09c90d892c845473ba92bb1e9ff0ead4f3eb84 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Mon, 28 Nov 2022 08:44:38 +0100
+Subject: [PATCH] configure: Avoid implicit ints and implicit function
+ declarations
+
+Implicit ints and implicit function declarations were removed from
+the C language in 1999. Relying on them can cause spurious autoconf
+check failures with compilers that do not support them in the default
+language mode.
+--- a/configure.in
++++ b/configure.in
+@@ -577,14 +577,16 @@ fi
+
+ AC_MSG_CHECKING(for working gettid)
+ AC_LINK_IFELSE([AC_LANG_SOURCE([#include <sys/types.h>
+- main() { pid_t a = gettid(); }])],
++ #include <unistd.h>
++ int main() { pid_t a = gettid(); }])],
+ [AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_GETTID, 1, [Full gettid function])],
+ [AC_MSG_RESULT(no)
+ AC_MSG_CHECKING(for working syscall(SYS_gettid))
+ AC_LINK_IFELSE([AC_LANG_SOURCE([#include <sys/types.h>
+ #include <sys/syscall.h>
+- main() { pid_t a = syscall(SYS_gettid); }])],
++ #include <unistd.h>
++ int main() { pid_t a = syscall(SYS_gettid); }])],
+ [AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_SYSCALL_GETTID, 1, [gettid syscall function])],
+ [AC_MSG_RESULT(no)]) ])
+@@ -625,7 +627,7 @@ AC_ARG_WITH(walltimer,
+ #include <stdio.h>
+ #include <time.h>
+ #include <syscall.h>
+- main() {
++ int main() {
+ struct timespec t1, t2;
+ double seconds;
+ if (syscall(__NR_clock_gettime,CLOCK_REALTIME_HR,&t1) == -1) exit(1);
+@@ -646,7 +648,7 @@ AC_ARG_WITH(walltimer,
+ #include <stdio.h>
+ #include <time.h>
+ #include <syscall.h>
+- main() {
++ int main() {
+ struct timespec t1, t2;
+ double seconds;
+ if (syscall(__NR_clock_gettime,CLOCK_REALTIME,&t1) == -1) exit(1);
+--
+2.38.1
diff --git a/dev-libs/papi/papi-6.0.0.1.ebuild b/dev-libs/papi/papi-6.0.0.1-r1.ebuild
index f63cab71642c..a42b0ca09acf 100644
--- a/dev-libs/papi/papi-6.0.0.1.ebuild
+++ b/dev-libs/papi/papi-6.0.0.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0.0.1-configure-clang16.patch
+)
+
src_prepare() {
default