summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-09-30 10:41:47 -0400
committerCraig Andrews <candrews@gentoo.org>2019-09-30 11:06:28 -0400
commitd31291b63e55dd924eb966ebcef97e7a8e1559ab (patch)
tree202f37c0ad0453ab82605a6931e44ba01e8a3fa3 /dev-libs/rocr-runtime/rocr-runtime-2.8.0.ebuild
parentdev-libs/roct-thunk-interface: 2.8.0 version bump (diff)
downloadgentoo-d31291b63e55dd924eb966ebcef97e7a8e1559ab.tar.gz
gentoo-d31291b63e55dd924eb966ebcef97e7a8e1559ab.tar.bz2
gentoo-d31291b63e55dd924eb966ebcef97e7a8e1559ab.zip
dev-libs/rocr-runtime: 2.8.0 version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime/rocr-runtime-2.8.0.ebuild')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-2.8.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-2.8.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-2.8.0.ebuild
new file mode 100644
index 000000000000..507d471dc104
--- /dev/null
+++ b/dev-libs/rocr-runtime/rocr-runtime-2.8.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/src"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCR-Runtime-roc-${PV}/src"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Runtime"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.0-cmake-install-paths.patch"
+)
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="nonfree"
+
+COMMON_DEPEND="sys-process/numactl"
+RDEPEND="${COMMON_DEPEND}
+ nonfree? ( dev-libs/hsa-ext-rocr )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/roct-thunk-interface-${PV}"
+
+src_prepare() {
+ sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
+ cmake-utils_src_prepare
+}