summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-08-20 14:24:55 -0400
committerCraig Andrews <candrews@gentoo.org>2019-08-20 14:24:55 -0400
commitd7bd5c1f06f791d5d354ca75100ed64204eea8bd (patch)
tree7c6ce9c541a21ee0329f5a20479aef96638d7a5d /dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
parentx11-libs/libdrm: Drop old versions (diff)
downloadgentoo-d7bd5c1f06f791d5d354ca75100ed64204eea8bd.tar.gz
gentoo-d7bd5c1f06f791d5d354ca75100ed64204eea8bd.tar.bz2
gentoo-d7bd5c1f06f791d5d354ca75100ed64204eea8bd.zip
dev-libs/rocr-runtime: Add nonfree flag for optional HSA image support
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime/rocr-runtime-9999.ebuild')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
index a31193337a6d..6a89ca2901eb 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
@@ -20,10 +20,13 @@ HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
+IUSE="nonfree"
-RDEPEND="sys-process/numactl"
-DEPEND="${RDEPEND}
- dev-libs/roct-thunk-interface"
+COMMON_DEPEND="sys-process/numactl"
+RDEPEND="${COMMON_DEPEND}
+ nonfree? ( dev-libs/hsa-ext-rocr )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/roct-thunk-interface-${PV}"
src_prepare() {
sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die