summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-06-23 12:10:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2022-06-23 13:10:33 +0200
commit287abc9288b00745e452ce78c52341668fa3e362 (patch)
treede036719699df4c982dc758a6aee574ea821f614 /dev-libs/sdformat/sdformat-9.8.0.ebuild
parentsci-electronics/gazebo: Remove old (diff)
downloadgentoo-287abc9288b00745e452ce78c52341668fa3e362.tar.gz
gentoo-287abc9288b00745e452ce78c52341668fa3e362.tar.bz2
gentoo-287abc9288b00745e452ce78c52341668fa3e362.zip
dev-libs/sdformat: bump to 9.8.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-libs/sdformat/sdformat-9.8.0.ebuild')
-rw-r--r--dev-libs/sdformat/sdformat-9.8.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/sdformat/sdformat-9.8.0.ebuild b/dev-libs/sdformat/sdformat-9.8.0.ebuild
new file mode 100644
index 000000000000..4a78444096c6
--- /dev/null
+++ b/dev-libs/sdformat/sdformat-9.8.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Simulation Description Format (SDF) parser"
+HOMEPAGE="http://sdformat.org/"
+SRC_URI="http://osrf-distributions.s3.amazonaws.com/sdformat/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# subslot = libsdformat major
+SLOT="0/9"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-libs/urdfdom-1:=
+ dev-libs/tinyxml
+ dev-libs/boost:=
+ sci-libs/ignition-math:6=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/ruby:*
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # get rid of default flags
+ sed -i -e '/_FLAGS_RELWITHDEBINFO/d' cmake/DefaultCFlags.cmake || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_INTERNAL_URDF=OFF
+ -DUSE_EXTERNAL_TINYXML=ON
+ )
+ cmake_src_configure
+}