summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-04-01 11:36:51 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-04-02 12:59:14 +0300
commit0d95c5f5c3341bea9d0c56841a0174921e6268db (patch)
tree408ef9178141cf8c6ea44400dca480aa754f9f96 /dev-libs/xapian
parentprofiles/desc: drop gcc_12_2_0 from ada (diff)
downloadgentoo-0d95c5f5c3341bea9d0c56841a0174921e6268db.tar.gz
gentoo-0d95c5f5c3341bea9d0c56841a0174921e6268db.tar.bz2
gentoo-0d95c5f5c3341bea9d0c56841a0174921e6268db.zip
dev-libs/xapian: add 1.4.22
Closes: https://bugs.gentoo.org/656438 Closes: https://bugs.gentoo.org/729408 Closes: https://bugs.gentoo.org/729412 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-libs/xapian')
-rw-r--r--dev-libs/xapian/Manifest1
-rw-r--r--dev-libs/xapian/xapian-1.4.22.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/xapian/Manifest b/dev-libs/xapian/Manifest
index d1737a07dba6..f2640b5f0189 100644
--- a/dev-libs/xapian/Manifest
+++ b/dev-libs/xapian/Manifest
@@ -1,2 +1,3 @@
DIST xapian-core-1.4.19.tar.xz 2994860 BLAKE2B 9566df1646192370e346c1b0d1e1cda68034fe5d3ab94835709f969df643fd36da49a58a2d3b4177a42faf5af2e71df771277848169ae62f94fe0bb0378ba6aa SHA512 d596058d7f9bfa0b73c5b6354331a799936b45f27012894f6792872ade8656bb0387b504aea8c1c3edfbd48787190452e7a49d2b62d181cb050c46edd3e67346
DIST xapian-core-1.4.21.tar.xz 3018384 BLAKE2B 61a25ee381c84e0a9f20650d94aa097225f2e947dafad7f6b5497db74f383f5b0fcf277a35ea27ff461b34cd2a9a0b6333f88264c5817cff09a2caf42fa3b398 SHA512 4071791daf47f5ae77f32f358c6020fcfa9aa81c15c8da25489b055eef30383695e449ab1cb73670f2f5db2b2a5f78056da0e8eea89d83aaad91dfe340a6b13a
+DIST xapian-core-1.4.22.tar.xz 3019608 BLAKE2B f4aec86cd5f63f6f1825a4f8f427ea23be2092ffb4ca11a2fdf20bdf652e7b9f768b1155bcf7ee5e5c5313206c92e1725d1b4d562e3074539a2e8f9901c44f8e SHA512 60d66adbacbd59622d25e392060984bd1dc6c870f9031765f54cb335fb29f72f6d006d27af82a50c8da2cfbebd08dac4503a8afa8ad51bc4e6fa9cb367a59d29
diff --git a/dev-libs/xapian/xapian-1.4.22.ebuild b/dev-libs/xapian/xapian-1.4.22.ebuild
new file mode 100644
index 000000000000..40a621af6000
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.4.22.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="https://xapian.org/"
+SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0/30" # ABI version of libxapian.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos ~x64-solaris"
+IUSE="doc static-libs cpu_flags_x86_sse cpu_flags_x86_sse2 +inmemory +remote"
+
+DEPEND="
+ sys-apps/util-linux
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS HACKING PLATFORMS README NEWS"
+
+src_configure() {
+ local -a myconf
+
+ if use cpu_flags_x86_sse2; then
+ myconf+=( --enable-sse=sse2 )
+ else
+ if use cpu_flags_x86_sse; then
+ myconf+=( --enable-sse=sse )
+ else
+ myconf+=( --disable-sse )
+ fi
+ fi
+
+ myconf+=( $(use_enable static-libs static) )
+
+ use inmemory || myconf+=( --disable-backend-inmemory )
+ use remote || myconf+=( --disable-backend-remote )
+
+ myconf+=(
+ --enable-backend-glass
+ --enable-backend-chert
+ --program-suffix=
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake check VALGRIND=
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if ! use doc; then
+ rm -r "${ED}/usr/share/doc/${PF}" || die
+ fi
+
+ einstalldocs
+
+ find "${ED}" -name "*.la" -type f -delete || die
+}