summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-01 20:11:18 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-01 22:14:03 -0500
commit1506ebf97c89d3276d385d416d49ccd6a2f3582b (patch)
treefe091d91c534f361ab4f0698d0c61c8001d5d257 /dev-libs
parentmedia-sound/jack2: stabilize 1.9.21-r1 for amd64, x86 (diff)
downloadgentoo-1506ebf97c89d3276d385d416d49ccd6a2f3582b.tar.gz
gentoo-1506ebf97c89d3276d385d416d49ccd6a2f3582b.tar.bz2
gentoo-1506ebf97c89d3276d385d416d49ccd6a2f3582b.zip
dev-libs/libchdr: add 0_p20221129
New snapshot to get the double file close fix in. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libchdr/Manifest1
-rw-r--r--dev-libs/libchdr/libchdr-0_p20221129.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libchdr/Manifest b/dev-libs/libchdr/Manifest
index 164e33ce04a5..fa3d68732afd 100644
--- a/dev-libs/libchdr/Manifest
+++ b/dev-libs/libchdr/Manifest
@@ -1 +1,2 @@
DIST libchdr-0_p20220917.tar.gz 1748223 BLAKE2B edb42f85d402955a82b79d62e3d47e614b01719ae641c7ed993ba479fb9762a7c66267212bb52d41a5fb175d11482ea7814dc120b0100e5c9210012274184d7f SHA512 acde5dd87b9e61862fa6da81cee715a14c2f350ce5167f85ccdeecc259aaa93ae500e403962b60a332f6a4dee3dc71031d23e2778650ac2702e02c8cc24f1431
+DIST libchdr-0_p20221129.tar.gz 1748187 BLAKE2B bc2f03d558e0f208ae3c51a53b2bbf630fb4cc502c18d83b31f184cf2c2f59e06dbb88c5399e01fb5f2436643a5095256bd31501a1531a043537a05c45c27be3 SHA512 4a72dcb376c451b74389650e121de06daae7cf0b293d7d66a8f7acf1b4f83355a2467a2d77e0953331ee5fffa243f713efb0878bb509384715e9c42a567a9b90
diff --git a/dev-libs/libchdr/libchdr-0_p20221129.ebuild b/dev-libs/libchdr/libchdr-0_p20221129.ebuild
new file mode 100644
index 000000000000..243e27033a4e
--- /dev/null
+++ b/dev-libs/libchdr/libchdr-0_p20221129.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+HASH_CHDR=a20e04c12c0c20048bf771da6df7aa2e51f5e0cb
+
+DESCRIPTION="Standalone library for reading MAME's CHDv1-v5 formats"
+HOMEPAGE="https://github.com/rtissera/libchdr/"
+SRC_URI="https://github.com/rtissera/libchdr/archive/${HASH_CHDR}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${HASH_CHDR}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_SYSTEM_ZLIB=yes
+ )
+
+ cmake_src_configure
+}