summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-01-14 14:33:40 +0800
committerSam James <sam@gentoo.org>2023-01-14 19:14:38 +0000
commit5c6f313be518087b4338480a852e8af3b6f4e0ec (patch)
treeb3e45d85c4d3580b7f2bd95c0d42dcce0585d819 /dev-libs
parentdev-libs/libgcrypt: fix build with lld-16 (diff)
downloadgentoo-5c6f313be518087b4338480a852e8af3b6f4e0ec.tar.gz
gentoo-5c6f313be518087b4338480a852e8af3b6f4e0ec.tar.bz2
gentoo-5c6f313be518087b4338480a852e8af3b6f4e0ec.zip
dev-libs/popt: fix build with lld-16
Signed-off-by: WANG Xuerui <xen0n@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/popt/popt-1.18.ebuild11
-rw-r--r--dev-libs/popt/popt-1.19.ebuild11
2 files changed, 18 insertions, 4 deletions
diff --git a/dev-libs/popt/popt-1.18.ebuild b/dev-libs/popt/popt-1.18.ebuild
index 435dcfdc5e35..cbbaee017f57 100644
--- a/dev-libs/popt/popt-1.18.ebuild
+++ b/dev-libs/popt/popt-1.18.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib-minimal libtool
+inherit flag-o-matic multilib-minimal libtool toolchain-funcs
DESCRIPTION="Parse Options - Command line parser"
HOMEPAGE="https://github.com/rpm-software-management/popt"
@@ -25,6 +25,13 @@ src_prepare() {
}
multilib_src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
local myeconfargs=(
$(use_enable static-libs static)
$(use_enable nls)
diff --git a/dev-libs/popt/popt-1.19.ebuild b/dev-libs/popt/popt-1.19.ebuild
index 483bb167bd28..bfabb9eff090 100644
--- a/dev-libs/popt/popt-1.19.ebuild
+++ b/dev-libs/popt/popt-1.19.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit multilib-minimal libtool
+inherit flag-o-matic multilib-minimal libtool toolchain-funcs
DESCRIPTION="Parse Options - Command line parser"
HOMEPAGE="https://github.com/rpm-software-management/popt"
@@ -29,6 +29,13 @@ src_prepare() {
}
multilib_src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
local myeconfargs=(
--disable-werror
$(use_enable static-libs static)