summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-12-17 10:52:47 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-12-17 10:53:26 +0100
commita14ca6e23a379d2edaedc792182a9920f9109662 (patch)
treeff6a60cca41c238a0ecb6a27174ecb404a339dbb /dev-libs
parentdev-libs/intel-compute-runtime: amd64 stable (diff)
downloadgentoo-a14ca6e23a379d2edaedc792182a9920f9109662.tar.gz
gentoo-a14ca6e23a379d2edaedc792182a9920f9109662.tar.bz2
gentoo-a14ca6e23a379d2edaedc792182a9920f9109662.zip
dev-libs/intel-compute-runtime: drop 22.39.24347
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.39.24347.ebuild79
2 files changed, 0 insertions, 80 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 61b75bb20e16..cb92af94456d 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,3 +1,2 @@
-DIST intel-compute-runtime-22.39.24347.tar.gz 5774278 BLAKE2B 27a288470f852ec87fae95a946fb87c9850cfc03e99bb869ebd474043d06f8b7beb2873b49d8fe4cc26f7db298c64d7b76d6bda6e6618c1ee8d1a9b658d5f45d SHA512 aef167fd4cc31d32c411ab54cf5f0e5fe13cda7e8fe4eac6aa3f9bf391b7ce9d51033d986d9c5e854c8f1492cce5022463e4b8b0ddc49319ef7bf362435808d5
DIST intel-compute-runtime-22.43.24558.tar.gz 5858180 BLAKE2B bed2ccd84424f8b4b76483d1cbffa9f587e666b8a24555d51de1edcfa23651a54b7d6b219fb27512cd8438127aa46945b181b3e94699444f36a05976b0b1206d SHA512 130849d1c3ef6586abbec3a3eb96397e6b5e861d17576b68b75d18023a4864938f82067079ea0d5475a8ac4f02cd0056d74d6b634894cbb5d0e23bef1c12fae0
DIST intel-compute-runtime-22.43.24595.35.tar.gz 5880869 BLAKE2B c9d4a16e9908427b69154a5a6550e4eec47bcce4fa811a9121c54de75bcd3e17e1d4cff8b1fa7486b2ffe0dd01f7fae06e5fd3b1d241378dcf521d1f8822bedb SHA512 0aab6cc16f7d523819c9a9eb58fba916c3b06c4be450c94cfc30b36038c768d6ddb79937ded7d9df68b7bdc97679756450c1c54844caed1655ddc688a6ae8a54
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.39.24347.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.39.24347.ebuild
deleted file mode 100644
index 46508e658896..000000000000
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.39.24347.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_BUILD_TYPE="Release"
-MY_PN="${PN/intel-/}"
-MY_P="${MY_PN}-${PV}"
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
-HOMEPAGE="https://github.com/intel/compute-runtime"
-SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="+l0 +vaapi"
-
-RDEPEND=">=media-libs/gmmlib-22.1.7:="
-
-DEPEND="
- ${DEPEND}
- >=dev-libs/intel-metrics-library-0_pre20220930:=
- dev-libs/libnl:3
- dev-libs/libxml2:2
- >=dev-util/intel-graphics-compiler-1.0.12149.1
- >=dev-util/intel-graphics-system-controller-0.8.4:=
- media-libs/mesa
- >=virtual/opencl-3
- l0? ( >=dev-libs/level-zero-1.8.5:= )
- vaapi? (
- x11-libs/libdrm[video_cards_intel]
- media-libs/libva
- )
-"
-
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( "README.md" "FAQ.md" )
-
-PATCHES=( "${FILESDIR}/${PN}-22.24.23453-remove-fortify-sources.patch" )
-
-src_prepare() {
- # Remove '-Werror' from default
- sed -e '/Werror/d' -i CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- # See https://github.com/intel/compute-runtime/issues/531
- filter-flags -flto=* -flto
-
- local mycmakeargs=(
- -DCCACHE_ALLOWED="OFF"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
- -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
- -DBUILD_WITH_L0="$(usex l0)"
- -DDISABLE_LIBVA="$(usex !vaapi)"
- -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
- -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
- -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
- -DSUPPORT_DG1="ON"
- -Wno-dev
-
- # See https://github.com/intel/intel-graphics-compiler/issues/204
- # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
-
- # If enabled, tests are automatically run during
- # the compile phase and we cannot run them because
- # they require permissions to access the hardware.
- -DSKIP_UNIT_TESTS="1"
- )
-
- cmake_src_configure
-}