summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-02-08 09:08:37 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-02-08 09:25:48 +0100
commitd85bff8b2422b2464c86e261c833355b9cc2b634 (patch)
treee0c440258d2ecd8f58f0ffc434ab72cb24d59616 /dev-libs
parentdev-lang/vala: version bump 0.36.7 → 0.36.11 (diff)
downloadgentoo-d85bff8b2422b2464c86e261c833355b9cc2b634.tar.gz
gentoo-d85bff8b2422b2464c86e261c833355b9cc2b634.tar.bz2
gentoo-d85bff8b2422b2464c86e261c833355b9cc2b634.zip
dev-libs/gmime: version bump 3.0.5 → 3.2.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gmime/Manifest1
-rw-r--r--dev-libs/gmime/gmime-3.2.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/gmime/Manifest b/dev-libs/gmime/Manifest
index 6c06943a2f18..f925f67ca75c 100644
--- a/dev-libs/gmime/Manifest
+++ b/dev-libs/gmime/Manifest
@@ -1,2 +1,3 @@
DIST gmime-2.6.23.tar.xz 5216588 BLAKE2B e173a7dbd418663ebbc55b856359bf9286c3791827f9b7f89da48dd7c3609e77312546f9489c08d34a7dcaeb78659789809d5fafc1323cbae9b9f1c4a316c659 SHA512 2ff6718b7a555cd5b34848399f29c7d0aa5a15e1f3cb46e9258c499e874191ee00f41b737386805d3000bad34367d174a25c45d38ba90cba7902400e733afa14
DIST gmime-3.0.5.tar.xz 764188 BLAKE2B 71daa5703c7a3e0e209a35908ef9fee40d494a5d2a3819d273408a36caee18dee6852a852a9d8757e2bf9d0b958235acb69cfa7538a8f670deb00c220f77a737 SHA512 658b9008ffdf8055ffa9dfe8a5a6036a487309b0419572a9376397f68a8fc17d36ba6a05d2dfcb2ad23e634dc9e2aedd2479df1bfa0b7f8944d4c294650cb6c8
+DIST gmime-3.2.0.tar.xz 1962544 BLAKE2B 2d5f9bbd2fb69015dfe52b7b9a8aaeba5d06c3c00e853212f098181efd1a30cb4588ebf173f1370dccc03d5a137ec1a0823608a7271ffd7d7e882a214c0e4189 SHA512 bb45f34b80ff237478602ff05ce0f736373185b7aa260c17aaf00a519d0b75ce9e24b0f6b256ce0f17b613e9f67174c54e302411110bf5f143947591f5f5aa43
diff --git a/dev-libs/gmime/gmime-3.2.0.ebuild b/dev-libs/gmime/gmime-3.2.0.ebuild
new file mode 100644
index 000000000000..3075f18979d7
--- /dev/null
+++ b/dev-libs/gmime/gmime-3.2.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit flag-o-matic gnome2 vala
+
+DESCRIPTION="Utilities for creating and parsing messages using MIME"
+HOMEPAGE="http://spruce.sourceforge.net/gmime/ https://developer.gnome.org/gmime/stable/"
+
+SLOT="3.0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="crypt doc idn static-libs test vala"
+
+RDEPEND="
+ >=dev-libs/glib-2.32.0:2
+ sys-libs/zlib
+ crypt? ( >=app-crypt/gpgme-1.8.0:1= )
+ idn? ( net-dns/libidn )
+ vala? (
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-1.30.0:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.8
+ virtual/libiconv
+ virtual/pkgconfig
+ doc? ( app-text/docbook-sgml-utils )
+ test? ( app-crypt/gnupg )
+"
+# gnupg is needed for tests if --enable-cryptography is enabled, which we do unconditionally
+
+src_prepare() {
+ gnome2_src_prepare
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ if [[ ${CHOST} == *-solaris* ]]; then
+ # bug #???, why not use --with-libiconv
+ append-libs iconv
+ fi
+
+ gnome2_src_configure \
+ $(use_enable crypt crypto) \
+ $(use_enable static-libs static) \
+ $(use_enable vala) \
+ $(use_with idn libidn) \
+ $(usex doc "" DB2HTML=)
+}
+
+src_compile() {
+ gnome2_src_compile
+ if use doc; then
+ emake -C docs/tutorial html
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc ; then
+ docinto tutorial
+ dodoc -r docs/tutorial/html/
+ fi
+}