summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-10-17 22:13:27 -0400
committerMatt Turner <mattst88@gentoo.org>2024-10-17 22:40:12 -0400
commiteac05af06e7fddf240fbbb67971de2087a133425 (patch)
treeb42d5daf4ecb435df46ddea334270075ca8a0ca1 /dev-libs
parentapp-misc/mosquitto: Version bump to 2.0.20 (diff)
downloadgentoo-eac05af06e7fddf240fbbb67971de2087a133425.tar.gz
gentoo-eac05af06e7fddf240fbbb67971de2087a133425.tar.bz2
gentoo-eac05af06e7fddf240fbbb67971de2087a133425.zip
dev-libs/wayland-protocols: Version bump to 1.38
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.38.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index 4b8696e3b2f3..aeb6213aec10 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,2 +1,3 @@
DIST wayland-protocols-1.36.tar.xz 95512 BLAKE2B 6c460106a2069ff9ce0b6c8221f85462e74d726ead69f6918417aac0cd24567251873ea05ec111a90f3385f4128e7e8d76aca42c7b1f89a070943c604b87573c SHA512 5448b9aedc953ce6be0f378da900c195c8743cb6001f615823b5fc9cab3e3ee54271132055743278e10decef7f8e9dcdeef31593a2a12062575fb90eb0084be0
DIST wayland-protocols-1.37.tar.xz 100356 BLAKE2B f341bdb50f4169112a89b1d834a4b62b59ab7c5d9b7640a3bb5a7d84dc055f390429b171de2038a70ec564c1431ecb95a036b053f18353f3ff936651240050de SHA512 57936a23d08957afa9563b51b2b195aa10410fa74176c0503f83b1544e243d4e5b99c3daf5fc14c0a68a78d3f5759e1a5ca9fe4ba22220cbf5328168903c7575
+DIST wayland-protocols-1.38.tar.xz 102648 BLAKE2B b07abed74b2f83247f3746414dc1f9e317793f9bc6ae7c1cb955d94149577964dee2ed0d658d4b9d9d7bd446509966393f4060b85db09b56292ddd9702bd1aee SHA512 43fc36d35bedb245deed0e2de246f42d2bbfa6ecafa094f2a7fb103d6df8ae28f3cc200bc5aa24745b9131a28381883c24779da0a6d9ac954753bd5ebb1405db
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.38.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.38.ebuild
new file mode 100644
index 000000000000..0bdb61d9ef92
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.38.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}