summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-07-04 14:24:44 -0400
committerMike Gilbert <floppym@gentoo.org>2017-07-04 14:24:44 -0400
commit2166da45d475dbf801665d0cdf0c2bb708db1c4f (patch)
tree2ccabc0638fe9f56ec2600359afd12f4ff0ead36 /dev-lua/lutok/lutok-0.4-r1.ebuild
parentvirtual/libudev: future-proof static-libs deps (diff)
downloadgentoo-2166da45d475dbf801665d0cdf0c2bb708db1c4f.tar.gz
gentoo-2166da45d475dbf801665d0cdf0c2bb708db1c4f.tar.bz2
gentoo-2166da45d475dbf801665d0cdf0c2bb708db1c4f.zip
dev-lua/lutok: convert to static lib
If dev-libs/lua becomes a static-only package, we need to become one too. Package-Manager: Portage-2.3.6_p9, Repoman-2.3.2_p77
Diffstat (limited to 'dev-lua/lutok/lutok-0.4-r1.ebuild')
-rw-r--r--dev-lua/lutok/lutok-0.4-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lua/lutok/lutok-0.4-r1.ebuild b/dev-lua/lutok/lutok-0.4-r1.ebuild
new file mode 100644
index 000000000000..12376e65bd0f
--- /dev/null
+++ b/dev-lua/lutok/lutok-0.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune
+
+DESCRIPTION="Lightweight C++ API library for Lua"
+HOMEPAGE="https://github.com/jmmv/lutok"
+SRC_URI="https://github.com/jmmv/lutok/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/lua:0
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-libs/atf
+ dev-util/kyua
+ )
+"
+
+src_configure() {
+ econf --disable-shared --enable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}