summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-29 21:28:45 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-29 21:28:45 +0100
commit478a3b53ce76fbd0b13d6a8c4a4f6b999e30394e (patch)
tree77508d647bb92f658d454efd073aa82792b3c98b /dev-ml/dune-site/dune-site-2.9.3.ebuild
parentsys-cluster/nullmpi: update EAPI 6 -> 8 (diff)
downloadgentoo-478a3b53ce76fbd0b13d6a8c4a4f6b999e30394e.tar.gz
gentoo-478a3b53ce76fbd0b13d6a8c4a4f6b999e30394e.tar.bz2
gentoo-478a3b53ce76fbd0b13d6a8c4a4f6b999e30394e.zip
dev-ml/dune-site: 2.9.3 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/dune-site/dune-site-2.9.3.ebuild')
-rw-r--r--dev-ml/dune-site/dune-site-2.9.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/dune-site/dune-site-2.9.3.ebuild b/dev-ml/dune-site/dune-site-2.9.3.ebuild
new file mode 100644
index 000000000000..e490578f9b6c
--- /dev/null
+++ b/dev-ml/dune-site/dune-site-2.9.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune multiprocessing
+
+DESCRIPTION="Embed locations informations inside executable and libraries"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-ml/dune-private-libs-${PV}:=[ocamlopt=]
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune build -p ${PN} @install -j $(makeopts_jobs) --display short || die
+}