summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 16:19:19 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:24 +1100
commitd998ac80025f27452fd697b17be14e3803976fa4 (patch)
treea056e63883ebfc3e2149af95e60671d247ee3a2e /dev-ml/dune/dune-2.7.1.ebuild
parentdev-ml/dose3: EAPI=7, patch for >=dev-lang/ocaml-4.06 (diff)
downloadgentoo-d998ac80025f27452fd697b17be14e3803976fa4.tar.gz
gentoo-d998ac80025f27452fd697b17be14e3803976fa4.tar.bz2
gentoo-d998ac80025f27452fd697b17be14e3803976fa4.zip
dev-ml/dune: Bump to 2.7.1
Co-Author: Alexis Ballier <aballier@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/dune/dune-2.7.1.ebuild')
-rw-r--r--dev-ml/dune/dune-2.7.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/dune/dune-2.7.1.ebuild b/dev-ml/dune/dune-2.7.1.ebuild
new file mode 100644
index 000000000000..5f9e9851d52e
--- /dev/null
+++ b/dev-ml/dune/dune-2.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing
+
+DESCRIPTION="A composable build system for OCaml"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="dev-lang/ocaml"
+RDEPEND="${DEPEND}
+ !dev-ml/jbuilder"
+BDEPEND=""
+
+RESTRICT="test"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ ocaml bootstrap.ml || die
+ ./dune.exe build -p "${PN}" --profile dune-bootstrap -j $(makeopts_jobs) || die
+}
+
+src_install() {
+ default
+ mv "${D}"/usr/doc "${D}"/usr/share/doc/${PF}
+ mv "${D}"/usr/man "${D}"/usr/share/man
+}