summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-20 13:11:50 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-20 13:29:22 +0200
commit5fc303b41809f83e059cd513b1841d358c6e10de (patch)
tree4ce9526c9beae10f21079e9fa322725851fd0977 /dev-ml/menhir/menhir-20230608.ebuild
parentdev-ml/menhir: drop old 20211012 (diff)
downloadgentoo-5fc303b41809f83e059cd513b1841d358c6e10de.tar.gz
gentoo-5fc303b41809f83e059cd513b1841d358c6e10de.tar.bz2
gentoo-5fc303b41809f83e059cd513b1841d358c6e10de.zip
dev-ml/menhir: bump to 20230608
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/menhir/menhir-20230608.ebuild')
-rw-r--r--dev-ml/menhir/menhir-20230608.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/menhir/menhir-20230608.ebuild b/dev-ml/menhir/menhir-20230608.ebuild
new file mode 100644
index 000000000000..0432f636319f
--- /dev/null
+++ b/dev-ml/menhir/menhir-20230608.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="LR(1) parser generator for the OCaml language"
+HOMEPAGE="http://gallium.inria.fr/~fpottier/menhir/"
+SRC_URI="https://gitlab.inria.fr/fpottier/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+src_install() {
+ dune_src_install menhir
+ dune_src_install menhirLib
+ dune_src_install menhirSdk
+}