summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-03-03 21:37:52 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-03-03 21:46:52 +0100
commitfaf9a3a627d7f135a720c225affdf01eef19f351 (patch)
tree7f75551b91818e19915c7b7726cbf5c7164ae81b /dev-ml/opam-repository/opam-repository-2.1.3.ebuild
parentdev-ml/opam-format: add 2.1.3 (diff)
downloadgentoo-faf9a3a627d7f135a720c225affdf01eef19f351.tar.gz
gentoo-faf9a3a627d7f135a720c225affdf01eef19f351.tar.bz2
gentoo-faf9a3a627d7f135a720c225affdf01eef19f351.zip
dev-ml/opam-repository: add 2.1.3
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/opam-repository/opam-repository-2.1.3.ebuild')
-rw-r--r--dev-ml/opam-repository/opam-repository-2.1.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/opam-repository/opam-repository-2.1.3.ebuild b/dev-ml/opam-repository/opam-repository-2.1.3.ebuild
new file mode 100644
index 000000000000..9fa56fc3a719
--- /dev/null
+++ b/dev-ml/opam-repository/opam-repository-2.1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="opam repository libraries"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/dev-ml/opam/opam-2.1.0-dose3-6.patch.xz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-ml/opam-format-${PV}:=
+ dev-ml/re:=
+ >=dev-ml/dose3-6.0:=
+ dev-ml/opam-file-format:=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${WORKDIR}"/opam-2.1.0-dose3-6.patch )
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}