summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-26 10:37:56 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-26 10:37:56 +0100
commit3c1848452d0bcd1d1c1bef831f53818b2f78dfcf (patch)
tree55ec4b8591575faf4c8fcd22ab0a86817768c3f6 /dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild
parentdev-python/paramiko: Fix broken whitespacing in version declaration of deps (diff)
downloadgentoo-3c1848452d0bcd1d1c1bef831f53818b2f78dfcf.tar.gz
gentoo-3c1848452d0bcd1d1c1bef831f53818b2f78dfcf.tar.bz2
gentoo-3c1848452d0bcd1d1c1bef831f53818b2f78dfcf.zip
dev-ml/pcre-ocaml: bump to 7.2.3
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild')
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild
new file mode 100644
index 000000000000..4eea14f760aa
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pcre-ocaml/ https://github.com/mmottl/pcre-ocaml"
+SRC_URI="https://github.com/mmottl/pcre-ocaml/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-libs/libpcre-4.5
+ >=dev-lang/ocaml-4:="
+DEPEND="${RDEPEND}"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}