summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-10-15 20:27:40 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-10-15 20:30:14 +0200
commit103881be4e9d3f83709f1d8b6cb5dd29c3accde5 (patch)
treef7d447874147772035221fd5a8a664e407f4bb9f /dev-ml/ppxlib/ppxlib-0.29.1-r2.ebuild
parentkde-plasma/xdg-desktop-portal-kde: drop 6.2.0 (diff)
downloadgentoo-103881be4e9d3f83709f1d8b6cb5dd29c3accde5.tar.gz
gentoo-103881be4e9d3f83709f1d8b6cb5dd29c3accde5.tar.bz2
gentoo-103881be4e9d3f83709f1d8b6cb5dd29c3accde5.zip
dev-ml/ppxlib: not for ocaml-5
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppxlib/ppxlib-0.29.1-r2.ebuild')
-rw-r--r--dev-ml/ppxlib/ppxlib-0.29.1-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/ppxlib/ppxlib-0.29.1-r2.ebuild b/dev-ml/ppxlib/ppxlib-0.29.1-r2.ebuild
new file mode 100644
index 000000000000..9c9eb99f2700
--- /dev/null
+++ b/dev-ml/ppxlib/ppxlib-0.29.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+# Note that new "major" versions may change which OCaml version they support
+# See:
+# https://github.com/ocaml-ppx/ppxlib/issues/243
+# https://github.com/ocaml-ppx/ppxlib/issues/232
+
+DESCRIPTION="Base library and tools for ppx rewriters"
+HOMEPAGE="https://github.com/ocaml-ppx/ppxlib"
+SRC_URI="https://github.com/ocaml-ppx/ppxlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=[ocamlopt?]
+ >=dev-ml/ocaml-migrate-parsetree-2.2.0:=[ocamlopt?]
+ dev-ml/sexplib0:=[ocamlopt?]
+ dev-ml/stdlib-shims:=[ocamlopt?]
+ >=dev-ml/ppx_derivers-1.2.1:=[ocamlopt?]
+ <dev-lang/ocaml-5
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ml/findlib:=[ocamlopt?]
+ >=dev-ml/base-0.11.0:=[ocamlopt?]
+ dev-ml/cinaps:=
+ dev-ml/re:=
+ >=dev-ml/stdio-0.11.0:=[ocamlopt?]
+ )
+"
+BDEPEND=">=dev-ml/dune-2.8"