summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2022-07-11 23:01:56 -0600
committerChristoph Junghans <junghans@gentoo.org>2022-07-11 23:06:57 -0600
commit7996e989b526cd3249eff05c7d65de3e0e984c49 (patch)
tree7db66e7c56aeba6c5a2505497194dca5d4d0d780 /dev-ml/ptime/ptime-1.0.0.ebuild
parentmedia-sound/rosegarden: removed obsolete 21.12 (diff)
downloadgentoo-7996e989b526cd3249eff05c7d65de3e0e984c49.tar.gz
gentoo-7996e989b526cd3249eff05c7d65de3e0e984c49.tar.bz2
gentoo-7996e989b526cd3249eff05c7d65de3e0e984c49.zip
dev-ml/ptime: initial commit
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'dev-ml/ptime/ptime-1.0.0.ebuild')
-rw-r--r--dev-ml/ptime/ptime-1.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/ptime/ptime-1.0.0.ebuild b/dev-ml/ptime/ptime-1.0.0.ebuild
new file mode 100644
index 000000000000..49d8a2f7ff44
--- /dev/null
+++ b/dev-ml/ptime/ptime-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam findlib
+
+DESCRIPTION="POSIX time for OCaml"
+HOMEPAGE="
+ https://erratique.ch/software/ptime
+ https://github.com/dbuenzli/ptime
+ https://opam.ocaml.org/packages/ptime/
+"
+SRC_URI="https://erratique.ch/software/ptime/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-ml/topkg
+"
+BDEPEND="dev-ml/ocamlbuild"
+
+OPAM_FILE=opam
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}