summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-04-27 08:57:13 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-04-27 08:57:13 +0200
commit6747fcab367277a6dba01527628c6c15b53ddb68 (patch)
treeb672de5b15ee5651203345c4363254f87ce6b085 /dev-ml/spawn/spawn-0.15.0-r1.ebuild
parentapp-misc/tmux-mem-cpu-load: keyword 3.5.1 for ~riscv (diff)
downloadgentoo-6747fcab367277a6dba01527628c6c15b53ddb68.tar.gz
gentoo-6747fcab367277a6dba01527628c6c15b53ddb68.tar.bz2
gentoo-6747fcab367277a6dba01527628c6c15b53ddb68.zip
dev-ml/spawn: change subslot
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/spawn/spawn-0.15.0-r1.ebuild')
-rw-r--r--dev-ml/spawn/spawn-0.15.0-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-ml/spawn/spawn-0.15.0-r1.ebuild b/dev-ml/spawn/spawn-0.15.0-r1.ebuild
new file mode 100644
index 000000000000..14f286a60e35
--- /dev/null
+++ b/dev-ml/spawn/spawn-0.15.0-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Spawning sub-processes"
+HOMEPAGE="https://github.com/janestreet/spawn"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-ml/ppx_expect )"