summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-02 15:40:25 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-02 20:29:06 +0100
commit3f869dbb64fad37ee11e7f8af58bcce3645cd586 (patch)
tree0e2bd6bfc255ecfce77049bdc9c730c50fcb2825 /dev-ml/yojson/yojson-1.3.2.ebuild
parentdev-ml/camlpdf: fix build with ocaml 4.03 (diff)
downloadgentoo-3f869dbb64fad37ee11e7f8af58bcce3645cd586.tar.gz
gentoo-3f869dbb64fad37ee11e7f8af58bcce3645cd586.tar.bz2
gentoo-3f869dbb64fad37ee11e7f8af58bcce3645cd586.zip
dev-ml/yojson: bump to 1.3.2
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/yojson/yojson-1.3.2.ebuild')
-rw-r--r--dev-ml/yojson/yojson-1.3.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/yojson/yojson-1.3.2.ebuild b/dev-ml/yojson/yojson-1.3.2.ebuild
new file mode 100644
index 000000000000..cab42fda852b
--- /dev/null
+++ b/dev-ml/yojson/yojson-1.3.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="http://mjambon.com/yojson.html"
+SRC_URI="https://github.com/mjambon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+ dev-ml/easy-format:=[ocamlopt]
+ dev-ml/biniou:=[ocamlopt]
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install BINDIR="${ED}"/usr/bin
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}