summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-07-01 18:39:54 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-07-01 18:39:54 +0200
commit2dedbfbe387d1b3a6d60d6d2716498d5016f182b (patch)
treefff650a2c4618170dd7d94d03df2a6ddf6a48ad1 /dev-ml
parentdev-ml/sedlex: add 3.2 (diff)
downloadgentoo-2dedbfbe387d1b3a6d60d6d2716498d5016f182b.tar.gz
gentoo-2dedbfbe387d1b3a6d60d6d2716498d5016f182b.tar.bz2
gentoo-2dedbfbe387d1b3a6d60d6d2716498d5016f182b.zip
dev-ml/tiny_httpd: add 0.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/tiny_httpd/Manifest1
-rw-r--r--dev-ml/tiny_httpd/files/tiny_httpd-0.16-noseq.patch11
-rw-r--r--dev-ml/tiny_httpd/tiny_httpd-0.16.ebuild50
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-ml/tiny_httpd/Manifest b/dev-ml/tiny_httpd/Manifest
index 528990da261e..e6f641205e00 100644
--- a/dev-ml/tiny_httpd/Manifest
+++ b/dev-ml/tiny_httpd/Manifest
@@ -1 +1,2 @@
DIST tiny_httpd-0.12.tar.gz 49124 BLAKE2B c3f407a605dabad1c710a696a3fca5dce04a75deb61e25e9ce572432e0d96cd3029628ea24d17d55a051d1d0f78aa1fd80797e7ff9c0bb7fc9d190e461784cd3 SHA512 99b4d01d4f4d138b122c689b8b3bc5043fc386d6686675311f625bf5fec72c6e1a7513712b00889fe17cd392b8c475440d4f89ee46392aff32ac6ccc39cefe09
+DIST tiny_httpd-0.16.tar.gz 66034 BLAKE2B 5bbbe87f48b19c2c8519d4c109e2b9eaef0ca5c42f77acdad8f6a216a23f59a68121d03d1ab95762999cb0f7089e0eee36ac0ed11151bbb72d4b9c5ab4314500 SHA512 fea483b931c1431117f7a1d3244749f856982e440d20b64a8d7c6fd841398eec3c7f91afaece707b5a35c0b332a06dde6464337aa1ac7b757f7952047981b130
diff --git a/dev-ml/tiny_httpd/files/tiny_httpd-0.16-noseq.patch b/dev-ml/tiny_httpd/files/tiny_httpd-0.16-noseq.patch
new file mode 100644
index 000000000000..8862a3361dc9
--- /dev/null
+++ b/dev-ml/tiny_httpd/files/tiny_httpd-0.16-noseq.patch
@@ -0,0 +1,11 @@
+--- a/src/dune 2024-07-01 18:38:15.116581859 +0200
++++ b/src/dune 2024-07-01 18:38:21.807507542 +0200
+@@ -1,7 +1,7 @@
+ (library
+ (name tiny_httpd)
+ (public_name tiny_httpd)
+- (libraries threads seq unix
++ (libraries threads unix
+ (select Tiny_httpd_log.ml from
+ (logs -> Tiny_httpd_log.logs.ml)
+ (-> Tiny_httpd_log.default.ml)))
diff --git a/dev-ml/tiny_httpd/tiny_httpd-0.16.ebuild b/dev-ml/tiny_httpd/tiny_httpd-0.16.ebuild
new file mode 100644
index 000000000000..a0453cacbc4c
--- /dev/null
+++ b/dev-ml/tiny_httpd/tiny_httpd-0.16.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Minimal HTTP server with a small request router"
+HOMEPAGE="
+ https://github.com/c-cube/tiny_httpd
+ https://opam.ocaml.org/packages/tiny_httpd
+"
+SRC_URI="https://github.com/c-cube/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="camlzip ocamlopt test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08
+ dev-ml/result:=
+ camlzip? ( >=dev-ml/camlzip-1.06:= )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-ml/qtest
+ dev-ml/ounit2
+ dev-ml/ptime
+ dev-ml/qcheck
+ net-misc/curl
+ )
+"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( camlzip )"
+
+PATCHES=( "${FILESDIR}"/${P}-noseq.patch )
+
+src_compile() {
+ local pkgs="tiny_httpd"
+ use camlzip && pkgs="${pkgs},tiny_httpd_camlzip"
+ dune build -p "${pkgs}" -j $(makeopts_jobs) || die
+}
+
+src_install() {
+ dune_src_install tiny_httpd
+ use camlzip && dune_src_install "tiny_httpd_camlzip"
+}