summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-05 04:39:20 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-05 04:40:12 +0100
commit79257f04da77e8188f658c42fd3ad08a60b84522 (patch)
treee58856b709d6544a863118c9f4a6de866fe79187 /dev-ml
parentapp-text/lesspipe: Stabilize 1.90 amd64, #828261 (diff)
downloadgentoo-79257f04da77e8188f658c42fd3ad08a60b84522.tar.gz
gentoo-79257f04da77e8188f658c42fd3ad08a60b84522.tar.bz2
gentoo-79257f04da77e8188f658c42fd3ad08a60b84522.zip
dev-ml/ocaml-sha: new package; add version 1.15.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-sha/Manifest1
-rw-r--r--dev-ml/ocaml-sha/metadata.xml18
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.15.1.ebuild22
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sha/Manifest b/dev-ml/ocaml-sha/Manifest
new file mode 100644
index 000000000000..d5f04d4492b9
--- /dev/null
+++ b/dev-ml/ocaml-sha/Manifest
@@ -0,0 +1 @@
+DIST ocaml-sha-1.15.1.tar.gz 15972 BLAKE2B c80fe4ba9a216fb88b0ca4cdf4f467450ad7225c9aa8fbb7389c85b8372de0a965683dc4a674c82ae4c2801b9f6a83777fbd3bfe5deb68af3d5e9193c058c9d9 SHA512 25af4f3fff6d5126e5e3b5f4dff4d6cc48396ffea48da186450236825bbb79110c7918a2bfa1c77dfaee9570965f9052d87c513d9f9da01208d95962b12cfd1c
diff --git a/dev-ml/ocaml-sha/metadata.xml b/dev-ml/ocaml-sha/metadata.xml
new file mode 100644
index 000000000000..34e9bead1fc0
--- /dev/null
+++ b/dev-ml/ocaml-sha/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ This is the binding for SHA interface code in OCaml. Offering the same
+ interface than the MD5 digest included in the OCaml standard library.
+ It's currently providing SHA1, SHA256 and SHA512 hash functions.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/djs55/ocaml-sha/issues/</bugs-to>
+ <remote-id type="github">djs55/ocaml-sha</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.15.1.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.15.1.ebuild
new file mode 100644
index 000000000000..d6ab5623b0f4
--- /dev/null
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.15.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="sha"
+
+inherit dune
+
+DESCRIPTION="Binding to the SHA cryptographic functions"
+HOMEPAGE="https://github.com/djs55/ocaml-sha"
+SRC_URI="https://github.com/djs55/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-ml/stdlib-shims:="
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"