summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-17 20:48:59 +0000
committerSam James <sam@gentoo.org>2020-10-17 20:59:29 +0000
commit85c19b5cfab222a98ad12e6909efc58fafe594d4 (patch)
tree09f1e61425514edd3e3573139b5a9a733a1f7d3c /dev-ml
parentsys-devel/autoconf: Revbump to improve AC_INIT arg quoting (diff)
downloadgentoo-85c19b5cfab222a98ad12e6909efc58fafe594d4.tar.gz
gentoo-85c19b5cfab222a98ad12e6909efc58fafe594d4.tar.bz2
gentoo-85c19b5cfab222a98ad12e6909efc58fafe594d4.zip
dev-ml/astring: bump to 0.8.5
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/astring/Manifest1
-rw-r--r--dev-ml/astring/astring-0.8.5.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/astring/Manifest b/dev-ml/astring/Manifest
index 90ced5f53e69..b4a531be8ac8 100644
--- a/dev-ml/astring/Manifest
+++ b/dev-ml/astring/Manifest
@@ -1 +1,2 @@
DIST astring-0.8.3.tbz 38710 BLAKE2B 253fe07b51996eb7b5f84e18d171b0f65cbb5abba9b241a02aa679765f3190edc636c1ba989910fde374a20c7615db1887eb73d8607f3bb8311e20ab6e67f670 SHA512 c7230e47b7ef14e6040fb18284a3d5aa8da1428b721cf91a7f17104cfb853be24b9c2aaa0b118bf3e050158aa8748311435417c6cf9014d260fb4379e4ead3e1
+DIST astring-0.8.5.tbz 37499 BLAKE2B bff0b9a295da9e33e0cc4bf1a5a0c3cec4010f477d67a39650bbb8e61f12e517cd5734f1e869d35448e4e555a04d0223b76181f29ee299ef9f19359c7d59e69a SHA512 b40634cc2053d651bce5c1974996b352ffa48ecac429919113840b2a807efb34387d950f12accb346afd5e40514cb90219d70b00109c30e1450c4e99f65c9856
diff --git a/dev-ml/astring/astring-0.8.5.ebuild b/dev-ml/astring/astring-0.8.5.ebuild
new file mode 100644
index 000000000000..a922e9b805db
--- /dev/null
+++ b/dev-ml/astring/astring-0.8.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Alternative String module for OCaml"
+HOMEPAGE="https://erratique.ch/software/astring https://github.com/dbuenzli/astring"
+SRC_URI="https://erratique.ch/software/astring/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+
+OCAML_DEP=">=dev-lang/ocaml-4.05.0:="
+BDEPEND="
+ dev-ml/ocamlbuild
+ dev-ml/findlib
+ dev-ml/topkg
+ ${OCAML_DEP}
+"
+RDEPEND="${OCAML_DEP}"
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}