summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-01 18:05:37 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-01 18:29:51 +0100
commitaf3337d22eaedccf45eb48a8f7ed8681a5ec80ac (patch)
tree35639dcf4ec27fd0f41047a0a4f530190565b89a /dev-ml
parentdev-vcs/pre-commit: bump to 4.0.1 (diff)
downloadgentoo-af3337d22eaedccf45eb48a8f7ed8681a5ec80ac.tar.gz
gentoo-af3337d22eaedccf45eb48a8f7ed8681a5ec80ac.tar.bz2
gentoo-af3337d22eaedccf45eb48a8f7ed8681a5ec80ac.zip
dev-ml/reason: bump to 3.14.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/reason/Manifest1
-rw-r--r--dev-ml/reason/reason-3.14.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/reason/Manifest b/dev-ml/reason/Manifest
index c65698ee2da6..d0a90abb924e 100644
--- a/dev-ml/reason/Manifest
+++ b/dev-ml/reason/Manifest
@@ -1,2 +1,3 @@
DIST reason-3.12.0.tar.gz 661530 BLAKE2B e2855359595f6240055577f4477975cbe4a836801f5db2431d9b243cc583938c401fcdb36a0e8636aa8ee1368f3565625580c10bef679f520a92fb937571b717 SHA512 4258ee4c6bdc20ff3034458e923e58db7da792d8e22a8ab0b281ea2d6bb503cad30356346e255ad9fcac6fbf4e6bf9bf8cacca08b37ece73f3311d9ef821f9f5
DIST reason-3.13.0.tar.gz 667524 BLAKE2B 2f27bc6ade3b1826687e6eed67c600603efd087ac2fa1e5b17560ff77233f9e77bccc98fafa142ff82291b8eb6aaa397557964b7c9be0c050ce8a5b9d33748d7 SHA512 afd7a714f836f38c5a7343a85a565ca5f20b109910973518d88befddd6c8fec0f2f3a2c54eebfb53f4bb52dcb45fdd30bb41663c7d979bca4f17aa1139ba5ce0
+DIST reason-3.14.0.tar.gz 675438 BLAKE2B 19ddd7ab800f33c9766665980a67a1df23121f063fc39827d78414762f0487c61f14ee97a9d84a6a521752b14ab17d1a15a3b2037e8304513e4f6e8a32ab9ca6 SHA512 feff9f5d7a00c39d528710401fa902a8a3a20808dbae2b32d5470dc1870a98b0fa1eef60f2fc8b8f4147401939ed53b1cca908b7cf2db82101c21e95de0840eb
diff --git a/dev-ml/reason/reason-3.14.0.ebuild b/dev-ml/reason/reason-3.14.0.ebuild
new file mode 100644
index 000000000000..a540ce8e9965
--- /dev/null
+++ b/dev-ml/reason/reason-3.14.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Simple, fast & type safe language that leverages JavaScript and OCaml"
+HOMEPAGE="https://reasonml.github.io/
+ https://github.com/reasonml/reason/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/reasonml/${PN}.git"
+else
+ SRC_URI="https://github.com/reasonml/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/dune-build-info:=[ocamlopt?]
+ dev-ml/fix:=[ocamlopt?]
+ dev-ml/menhir:=[ocamlopt?]
+ dev-ml/merlin-extend:=[ocamlopt?]
+ dev-ml/ppx_derivers:=[ocamlopt?]
+ dev-ml/ppxlib:=[ocamlopt?]
+ dev-ml/utop:=[ocamlopt?]
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_install() {
+ dune-install reason rtop
+
+ dodoc ./*.md ./docs/*.md
+}