summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorRafael Kitover <rkitover@gmail.com>2022-12-02 21:20:01 +0000
committerSam James <sam@gentoo.org>2022-12-03 08:00:51 +0000
commitb68624d71736a1ec74043a9d835b8fcd155492bb (patch)
tree76da741881d15f7e394e9fe43d92e6e141abc9cf /dev-ml
parentdev-ml/ocaml-fileutils: drop 0.6.2-r1 (diff)
downloadgentoo-b68624d71736a1ec74043a9d835b8fcd155492bb.tar.gz
gentoo-b68624d71736a1ec74043a9d835b8fcd155492bb.tar.bz2
gentoo-b68624d71736a1ec74043a9d835b8fcd155492bb.zip
dev-ml/ocaml-fileutils: add 0.6.4
Remove the 'v' version prefix, that is no longer used. Remove the edit to use ounit2 for tests, that is no longer necessary. Signed-off-by: Rafael Kitover <rkitover@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28516 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-fileutils/Manifest2
-rw-r--r--dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4.ebuild25
2 files changed, 26 insertions, 1 deletions
diff --git a/dev-ml/ocaml-fileutils/Manifest b/dev-ml/ocaml-fileutils/Manifest
index da1779a20b3f..f519da53cadb 100644
--- a/dev-ml/ocaml-fileutils/Manifest
+++ b/dev-ml/ocaml-fileutils/Manifest
@@ -1,2 +1,2 @@
-DIST ocaml-fileutils-0.6.2.tar.bz2 43060 BLAKE2B 20828875a25b1a9d2a41bf495cda00b0ac753efa20111b32a9d2ca439a56e9f07bf0953d16ee9148cf065e204fa1d8d624eaa89f6f4ae7e1613fdaa7cb44fc24 SHA512 104c7389832f22ec189ce6f1596144b28dcaeea7d23d5b19d369c44e54326e97fcb7b4f4c4a8d2965523e63b35b594a1351b7e630dde590871efe512fe38853c
DIST ocaml-fileutils-0.6.3.tar.bz2 43157 BLAKE2B a9adf17d028abd664dbdec3fefa301a6b502941a6da4ef9c3ef02b876f187d224e404f6a9ffb5460035ba475154c60109a5218cb8b9bb36153ca791f8d218e7d SHA512 2c5e75b894e9f5e3b003d61977a87f5c6964a89d844949eedc55f97c5875cc52052182420bbb4e73925d306479c66400df74e4adfccc5b2102347d13e99505cf
+DIST ocaml-fileutils-0.6.4.tar.bz2 43144 BLAKE2B e0024b93c17d11c9c3068da3141c7676bf70feb21fc886d79f793396194f6d5052be887734decd29fbd524d127e0b8afcd41790c9f378e000fcb92cd73e0a2ce SHA512 7053f8d92655d5631f1ec61ab7f9e3f6e3afedbe435038858dd9a026b9c769c6182afaa436491a398e7c4513b384a609e016718e030855996b2d9d54b461bd19
diff --git a/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4.ebuild b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4.ebuild
new file mode 100644
index 000000000000..04a39c41c268
--- /dev/null
+++ b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="fileutils"
+
+inherit dune
+
+DESCRIPTION="Pure OCaml functions to manipulate real file (POSIX like) and filename"
+HOMEPAGE="https://github.com/gildor478/ocaml-fileutils"
+SRC_URI="https://github.com/gildor478/${PN}/releases/download/v${PV}/${DUNE_PKG_NAME}-${PV}.tbz -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-ml/ounit2-2.0.0
+ >=dev-ml/stdlib-shims-0.2.0"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.md" "CHANGES.md" "LICENSE.txt" )
+
+S="${WORKDIR}/${DUNE_PKG_NAME}-${PV}"