summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Alien-SDL
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Alien-SDL')
-rw-r--r--dev-perl/Alien-SDL/Alien-SDL-1.440.0.ebuild39
-rw-r--r--dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild40
-rw-r--r--dev-perl/Alien-SDL/Alien-SDL-1.446.0.ebuild42
-rw-r--r--dev-perl/Alien-SDL/Manifest3
-rw-r--r--dev-perl/Alien-SDL/files/Alien-SDL-1.444.0-fix-build-option.patch31
-rw-r--r--dev-perl/Alien-SDL/metadata.xml10
6 files changed, 165 insertions, 0 deletions
diff --git a/dev-perl/Alien-SDL/Alien-SDL-1.440.0.ebuild b/dev-perl/Alien-SDL/Alien-SDL-1.440.0.ebuild
new file mode 100644
index 000000000000..aac029c20707
--- /dev/null
+++ b/dev-perl/Alien-SDL/Alien-SDL-1.440.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=FROGGS
+MODULE_VERSION=1.440
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="building, finding and using SDL binaries"
+
+SLOT="0"
+KEYWORDS="amd64 hppa x86"
+
+# File::Fetch, File::Find, Test::More -> dev-lang/perl
+RDEPEND="dev-perl/Archive-Extract
+ dev-perl/Archive-Zip
+ dev-perl/Capture-Tiny
+ dev-perl/File-ShareDir
+ dev-perl/File-Which
+ dev-perl/Text-Patch
+ media-libs/libsdl
+ virtual/perl-Archive-Tar
+ virtual/perl-Digest-SHA
+ virtual/perl-ExtUtils-CBuilder
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/Module-Build
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp"
+DEPEND=${RDEPEND}
+
+SRC_TEST=do
+myconf='--with-sdl-config'
+
+src_prepare() {
+ tc-export CC
+ perl-module_src_prepare
+}
diff --git a/dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild b/dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild
new file mode 100644
index 000000000000..c5c8b6675c41
--- /dev/null
+++ b/dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=FROGGS
+MODULE_VERSION=1.444
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="building, finding and using SDL binaries"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+# File::Fetch, File::Find, Test::More -> dev-lang/perl
+RDEPEND="dev-perl/Archive-Extract
+ dev-perl/Archive-Zip
+ dev-perl/Capture-Tiny
+ dev-perl/File-ShareDir
+ dev-perl/File-Which
+ dev-perl/Text-Patch
+ media-libs/libsdl
+ virtual/perl-Archive-Tar
+ virtual/perl-Digest-SHA
+ virtual/perl-ExtUtils-CBuilder
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/Module-Build
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp"
+DEPEND=${RDEPEND}
+
+src_prepare() {
+ tc-export CC
+ epatch "${FILESDIR}"/${P}-fix-build-option.patch
+ perl-module_src_prepare
+}
+
+SRC_TEST=do
+myconf='--with-sdl-config'
diff --git a/dev-perl/Alien-SDL/Alien-SDL-1.446.0.ebuild b/dev-perl/Alien-SDL/Alien-SDL-1.446.0.ebuild
new file mode 100644
index 000000000000..424099583972
--- /dev/null
+++ b/dev-perl/Alien-SDL/Alien-SDL-1.446.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=FROGGS
+MODULE_VERSION=1.446
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="building, finding and using SDL binaries"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+# File::Fetch, File::Find, Test::More -> dev-lang/perl
+RDEPEND="
+ dev-perl/Archive-Extract
+ dev-perl/Archive-Zip
+ dev-perl/Capture-Tiny
+ dev-perl/File-ShareDir
+ dev-perl/File-Which
+ dev-perl/Text-Patch
+ media-libs/libsdl
+ virtual/perl-Archive-Tar
+ virtual/perl-Digest-SHA
+ virtual/perl-ExtUtils-CBuilder
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/Module-Build
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ tc-export CC
+ epatch "${FILESDIR}"/${PN}-1.444.0-fix-build-option.patch
+ perl-module_src_prepare
+}
+
+SRC_TEST=do
+myconf='--with-sdl-config'
diff --git a/dev-perl/Alien-SDL/Manifest b/dev-perl/Alien-SDL/Manifest
new file mode 100644
index 000000000000..88f29a80cd4a
--- /dev/null
+++ b/dev-perl/Alien-SDL/Manifest
@@ -0,0 +1,3 @@
+DIST Alien-SDL-1.440.tar.gz 346309 SHA256 cc25c9319d2db984b049eed5559582b2a6e0072af9b48d621a7772a1dcd18961 SHA512 3af6f80f376927d031a5ff1dfefb2b24d6824657424010970a4ae11d539893ac09ebfe0c2555da1600d5d9a4f830f7d5ab51593991eb8d239eaacff9f7328987 WHIRLPOOL 1cef55c0dbf33e7ebcc2d9200dce49603d1a9e55e8f7a5192fd8d29cbc8d624410490e53e5998206b66ea5cfb078cef5ff974bb821c57f1ab028fdd7a40c0d2a
+DIST Alien-SDL-1.444.tar.gz 349527 SHA256 66cc4f1f4d55a3fd34869838f21bc0ed4a1a0c1f07158f85a0edd12fc35dbc74 SHA512 0c638351a22efcb83eb24b1c28a7db4a05c1f685717fcd735cd03692e11589649e1f7fed4b6c52c0b8f48c208b5daf301432bd986375f966f02c61d922f2cd79 WHIRLPOOL 87c0bb3a827265206332a63d29ba3fed4b1dd31546a601f78ed23e4dc5693b8784a7e47771823bd488bb6c19348f09da6c46d2cc254c272d82c4b1e5a840fdfc
+DIST Alien-SDL-1.446.tar.gz 350448 SHA256 c9aa2c9dc3c63d89773c7d7203f2a46d1b924d0c72d9f801af147a3dc8bc512a SHA512 dfb5f104f449857b9567ca93a0c3b15aed2618e27019569c95c4b7469e1f7d5cc390fe2dda9c6add41e9648c1f6efe053d08a4bd0fcc5bc546a217721bea824c WHIRLPOOL d449168885362a7533eb167ae3d4655b1bdb0a3188c8cbd44c6aa4b38c68d816117954434d51b711d7cf5fc54d511b2dd53952ae1c6e44e106918b0960b6bd0f
diff --git a/dev-perl/Alien-SDL/files/Alien-SDL-1.444.0-fix-build-option.patch b/dev-perl/Alien-SDL/files/Alien-SDL-1.444.0-fix-build-option.patch
new file mode 100644
index 000000000000..7d58b8b4e3dd
--- /dev/null
+++ b/dev-perl/Alien-SDL/files/Alien-SDL-1.444.0-fix-build-option.patch
@@ -0,0 +1,31 @@
+Description: fix build option handling
+ GetOptions handles all command arguments without
+ letting Module::Build handles the options. One
+ should not use GetOptions with Module::Build options setup.
+ .
+ So I noved travis option spec into Module::Build
+Author: dod
+--- a/Build.PL
++++ b/Build.PL
+@@ -7,9 +7,7 @@
+ use My::Utility qw(check_config_script check_prebuilt_binaries check_prereqs_libs check_prereqs_tools $source_packs
+ check_perl_buildlibs);
+
+-use Getopt::Long;
+ my ( $ans, $travis ) = 0;
+-GetOptions( "travis" => \$travis );
+
+ print "Welcome to Alien::SDL module installation\n";
+ print "-----------------------------------------\n";
+@@ -98,7 +96,10 @@
+ repository => 'http://github.com/PerlGameDev/Alien-SDL'
+ }
+ },
+- get_options => { 'with-sdl-config' => { qw(type :s store) => \$sdl_config } },
++ get_options => {
++ 'with-sdl-config' => { qw(type :s store) => \$sdl_config },
++ 'travis' => { store => \$travis },
++ },
+ dynamic_config => 1,
+ create_readme => 1,
+ share_dir => 'sharedir',
diff --git a/dev-perl/Alien-SDL/metadata.xml b/dev-perl/Alien-SDL/metadata.xml
new file mode 100644
index 000000000000..243b6609687d
--- /dev/null
+++ b/dev-perl/Alien-SDL/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="cpan">Alien-SDL</remote-id>
+ <remote-id type="cpan-module">Alien::SDL</remote-id>
+ </upstream>
+</pkgmetadata>