summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-03-23 17:08:28 +1300
committerKent Fredric <kentnl@gentoo.org>2017-03-23 17:08:48 +1300
commit16dd0a4ebec32c4583fe453f0e05be80f657dd1b (patch)
treed6826d1b168a5302474b06b88d47fbbe97e6c7c8 /dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.350.0.ebuild
parentmedia-video/totem: bump to 3.22.1 (diff)
downloadgentoo-16dd0a4ebec32c4583fe453f0e05be80f657dd1b.tar.gz
gentoo-16dd0a4ebec32c4583fe453f0e05be80f657dd1b.tar.bz2
gentoo-16dd0a4ebec32c4583fe453f0e05be80f657dd1b.zip
dev-perl/Apache-LogFormat-Compiler: Bump to version 0.350.0
Upstream: - Fix '.' in @INC issues - Switch to Module::Build::Tiny Bug: https://bugs.gentoo.org/613594 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.350.0.ebuild')
-rw-r--r--dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.350.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.350.0.ebuild b/dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.350.0.ebuild
new file mode 100644
index 000000000000..869d86c80db7
--- /dev/null
+++ b/dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.350.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KAZEBURO
+DIST_VERSION=0.35
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="Compile an Apache log format string to perl-code"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+# POSIX -> perl
+RDEPEND="
+ >=dev-perl/POSIX-strftime-Compiler-0.300.0
+ virtual/perl-Time-Local
+ >=dev-lang/perl-5.8.4"
+
+# HTTP::Request::Common -> HTTP-Message
+# Test::More -> perl-Test-Simple
+# URI::Escape -> URI
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.35.0
+ test? (
+ dev-perl/HTTP-Message
+ dev-perl/Test-MockTime
+ >=virtual/perl-Test-Simple-0.980.0
+ dev-perl/Test-Requires
+ >=dev-perl/Try-Tiny-0.120.0
+ >=dev-perl/URI-1.600.0
+ )
+"