summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-04 01:05:46 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-04 02:59:35 +1200
commita90d776a610fe64027ef7fc4810423b774385ba3 (patch)
tree86bbe06d95a81b52e6579a86acf250d1b78d3f01 /dev-perl/Bio-DB-HTS/Bio-DB-HTS-3.10.0-r1.ebuild
parentdev-perl/B-COW: -r Bump for CFLAGS love (diff)
downloadgentoo-a90d776a610fe64027ef7fc4810423b774385ba3.tar.gz
gentoo-a90d776a610fe64027ef7fc4810423b774385ba3.tar.bz2
gentoo-a90d776a610fe64027ef7fc4810423b774385ba3.zip
dev-perl/Bio-DB-HTS: -r1 bump for EAPI7 + toolchain love
- EAPI7 - Ensure not breaking when LD=!ccld - Ensure passing CFLAGS to make/compiler - Populate more remote-id's in metadata.xml Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Bio-DB-HTS/Bio-DB-HTS-3.10.0-r1.ebuild')
-rw-r--r--dev-perl/Bio-DB-HTS/Bio-DB-HTS-3.10.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-perl/Bio-DB-HTS/Bio-DB-HTS-3.10.0-r1.ebuild b/dev-perl/Bio-DB-HTS/Bio-DB-HTS-3.10.0-r1.ebuild
new file mode 100644
index 000000000000..dcae1156e881
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/Bio-DB-HTS-3.10.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=AVULLO
+DIST_VERSION=3.01
+
+inherit perl-module
+
+DESCRIPTION="Perl bindings for sci-libs/htslib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sci-biology/bioperl
+ sci-libs/htslib:=
+"
+DEPEND="
+ dev-perl/Module-Build
+ sci-libs/htslib:=
+"
+BDEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( dev-perl/Test-LeakTrace )"
+
+PATCHES=(
+ "${FILESDIR}/2.11-build_env_ldflags.patch"
+ "${FILESDIR}/2.11-build_split_htslib_opts.patch"
+)
+
+src_configure() {
+ local myconf="--htslib-includedir=${EPREFIX}/usr/include/htslib --htslib-libdir=${EPREFIX}/usr/$(get_libdir)"
+ unset LD
+ if [[ -n "${CCLD}" ]]; then
+ export LD="${CCLD}"
+ fi
+ perl-module_src_configure
+}
+src_compile() {
+ ./Build --config optimize="${CFLAGS}" build || die
+}